Powersupply without LiPo battery

I bought a Pixhawk 4 to do some testing with servos and some other things. However, I didn’t buy a LiPo battery pack or anything like that yet. So I was wondering if it’s possible to supply power to the PM07 using some alternative powersupply?
I was thinking of using powering a breadboard with a 5V power supply and then connecting the XT60 connector of the PM07 with the breadboard using jumper cables. Is this a viable option? Does anyone know of another option? Maybe someone can link me to some kind of a powersupply with a female XT60 connector?

I use a 12v 20 amp supply I got on ebay for testing w/o a battery.
The 5V supply should work to power the PX and servos.
I doubt you will find anything with an XT-60 but you can get them on Amazon or ebay pretty cheap.

1 Like

@jimdgit Thanks for your answer.

But how do you connect a random 12v power supply to your Power management board if it doesn’t have an XT-60 connector?

You buy some XT-60 connectors, some wire and then solder up a cable.
Like:
https://www.amazon.com/gp/product/B00XBLLG5S/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1

1 Like

@jimdgit Allright, gonna do that thanks. Is there a specific set or range of voltages that I can apply to the PM? And also (I don’t know so much about electronics) isn’t a current of 20A really much? Sounds like a lot to me.

With 20 amp I can run the motors,if I had really a long wire I could probably fly it, but really I had the power supply around to drive a charger.
If your hook into the PM07 it’s good up to a 12S battery which is like 50V, so no worries there.

1 Like

Thanks a lot, this has been very helpful! I guess, I will get those XT-60 connectors you suggested and a normal 12v/1A power supply or smth like this.

If you just want to play with some servos, you can leave the PM07 in the box, power the Pixhawk with USB, and supply whatever voltage you need for the servos directly to the servo rail in an empty output. If you need to arm then you’ll need to disable the USB arming check under Circuit Breaker in the parameters. (Set CBRK_USB_CHK = 197848.) You’ll usually want to set this back if you add motors and a power supply.

dude, put down the pipe…

@benasena I don’t understand this. If I don’t use the PM07: where do I connect the signal cabels of the servos to? Or how do the servos get the signals from I/O OUT? I can hardly connect the servos directly to the Pixhawk 4 or can I?

@moonmotor Who are you adressing and what do you want to say?

Sorry, I forgot the Pixhawk 4 doesn’t have its own servo rails and uses the PM07 as a breakout. That’s embarrassing, especially since I have a couple. I believe you can still connect nothing to the XT60, connect USB to the Pixhawk, and connect servo power to the servo rails directly to power the servos. I can double check with mine for you.

You could also connect the Pixhawk’s I/O pins to a breadboard and hook them up to your servos through there according to this (without PM07).

1 Like

No worries, thanks for clarrifying :slight_smile:

Sounds legit. I’ll give this a try.

And how exactly would I do that? I would have to cut one of my 8 Pin JST-G cables in the middle, connect it to I/O OUT of pixhawk and then connect the wires to the breadboard files? Thing is: those JST-G cables are a limited ressource for me currently :smiley:

1 Like

If you had something like Figure 11 here:

Or this:

It would make more sense, but in your case the first option is more convenient. I just wanted to highlight that it’s possible without the rest of the functions included in PM07 :slight_smile:

1 Like

@benasena Great, thanks a lot, this has been incredibly helpful to me. I do have these thingies from Figure 11. How do you call those?

I’m quite new to all these electronics and sometimes I’m yet not able to connect the dots myself. I’ll get there.

1 Like

That’s what I was trying to figure out so I could Google that picture for you. I would call it a 10-pin JST-GH to 8 Ch servo rail breakout board, but that doesn’t seem to search well.

This already answered my question. The word I was looking for is “breakout board”. :wink:

1 Like

@benasena I just tried arming with USB connected. First it didn’t arm because of the USB, so I set CBRK_USB_CHK to the correct value and now QGC tells me “Arming denied. Check battery!”. Any ideas on how to prevent this from happening?

@max11gen have you tried setting the battery failsafe values to 0?

@benasena No, but I managed to solve the problem by setting CBRK_SUPPLY_CHK as suggested in this topic.

However, I’m already stuck on the next one :roll_eyes: Now it won’t arm, because of the safety switch and I can’t figure out how to go around that one. I don’t have a safety switch… There is a module that is called safety_button but stoping that module, doesn’t change the arm behaviour. You got any ideas on that one?

IIRC that’s
CBRK_IO_SAFETY = 22027
See:

http://docs.px4.io/master/en/advanced_config/parameter_reference.html#circuit-breaker