Battery Configuration - 'Arming Denied: Check Battery'

Hello!

I’ve got a problem and would like to seek some help.
When I want to start my drone I get the warning Arming Denied: Check Battery I guess it is because QGC and my drone report the drones battery percentage as 0%. In reality it doesn’t matter how much I charged the battery even full charged ones will not be recognized in any % value. The current Voltage of my battery is fine and well calibrated compared to external measurements.
So I feel a bit confused.

Below is a pic of my current settings:
Im using a flamewheel quad with a pixhawk 2.1 (Cube) and a 3s LiPo.

The parameters

  • BAT_A_PER_V
  • BAT_CNT_V_CURR
  • BAT_CNT_V_VOLT
    should all be defaulted - but when I set them to ‘-1’ they jump right back to the values you see there. Doesn’t know whether this is wanted behavior or some buggy code?!
    My firmware is the current Master branch for enabling a companion computer (RaspPi in my case).

If someone could help me it would be great - right now I use the CBRK_SUPPLY_CHK to ignore the problem and allow arming for the drone - but in future I would like to fix this…

Greetings


go to voltage divider and put the actual voltage. and reboot your craft, it will show the correct value

Yeah thanks I did it again and realized something:
beforehand I calculated the Voltage divider for a single cell and not for the whole copter…

Now it is calibrated with the whole system voltage and I see the % values - thanks a lot

Hello, hsu, I have the same problem. Could you please explain a little how you fixed this problem?

@robin-ecn Here is a detailed answer: https://docs.px4.io/en/config/battery.html

did you solved your problem?
For me it was quite simple - if you follow the link bresch posted along you find how to setup the battery configuration.

You need something to measure the voltage of the whole battery not just the cell voltage. And use this measurement to calc the Voltage Divider in qgc.

For full/empty voltage of each individual cell you can use the basic values for LiPos if you don’t have something to measure each cells individual voltage.

I just got confused and tried to configure my Volatge Divider with a single cell voltage which didn’t worke

Yes, thanks to the help from bresch, I solved this problem. Thank you very much

It works!!! Merci beaucoup!!!