DJI F450 ESC Beeping

#1

My setup is:
-DJI F450 with DJI e series 430 lite ESC and 2312E motors
-Futaba R7008SB receiver, T14SG remote
-Pixhawk 4 firmware 1.8.0dev, PM07-V2.1 Power Management Board, Pixhawk 4 GPS Module

I connected:
PWR1 in the power board to the power 1 at the Pixhawk 4
PWR2 in the power board to the power 2 at the Pixhawk 4
GPS Module to the GPS port in Pixhawk 4
I/O PWM Out in Pixhawk to I/O PWM IN at Power Board
FMU PWM Out in Pixhawk to FMU PWM IN at Power Board
DSM/SBUS RC in Pixhawk to S.BUS2 at the receiver
Motor 1 to FMU-PWM-Out 1
Motor 2 to FMU-PWM-Out 2
Motor 3 to FMU-PWM-Out 3
Motor 4 to FMU-PWM-Out 4
Battery connector to distribution board on the DJI
ESC Power to the distribution board on DJI

I connected the usb to my laptop (mac) opened the Qgroundcontrol:
Firmware updated to 1.8.0dev
Airframe selected Quadrotor X (DJI Flame Wheel F450) --Restarted
Sensor calibration (all done Compass, Gyroscope, Accelerometer, Level Horizon)
Radio Calibrated
Flight mode Stabilized, Position, Altitude
Power , Modified the full voltage to 4.2v

I tried to calibrate the ESC, I plugged the battery when it ask, the front 2 motor start spinning with out stopping until I removed the battery.
disconnect the USB turned on my Remote then the Drone I have the ESC beeping
Beep – Beep – Beep – Beep then Beep Beep Beep Beep Beep with out stopping

I reset the Pixhawk and repeated every thing with out doing the ESC calibration the same thing

So what I am doing wrong


Thank you for your reply

2 Likes
#2

Hi @Mohamad_Hariri ,

I would recommend you to read this section again: https://docs.px4.io/en/assembly/quick_start_pixhawk4.html#power
In a standard configuration, the motors should be attached to the M1..8 pads that are connected to the I/O PWM OUT port. If you want to use the FMU PWM headers of the power distribution board (PDB), there are three possibilities:

  1. Connect the I/O port of the PixHawk to the FMU port of the PDB (no recommanded)
  2. Set the parameter SYS_USE_IO to zero or “Disabled”
  3. If you received a PWM breakout board with your kit, you could attached it to the I/O PWM OUT port of the Pixhawk

Using the 2nd solution also reduces the delay in the control loop but disables the I/O co-processor (not really needed on a quad).

Hope it helped,
Good luck!

3 Likes
#3

Thank you very much I soldered the esc data to the motor pin directly and no more beeping
I also needed to disable the safety switch replacing the value for “CBRK_IO_SAFETY” to 22027 instead of 0
Now I am searching how to stop the motors from spinning after arming and the throttle is low to the minimum

#4

I’m glad it worked :slight_smile:
Having the motors spinning at idle speed while being armed and at zero throttle is the expected behavior.

Not recommended, but I still give you the answer:
If you truly want to have the motors stopped when armed and at zero throttle, you can set the PWM_MIN parameter to a low value and MPC_THR_MIN to zero. To avoid uncontrolled free fall during flight, you should then enable airmode (MC_AIRMODE) and make sure that the pwm min value is really close to the motor starting value and that you have good ESCs that can quickly restart, even if the rotor is already spinning.

2 Likes
#5

Thank you very much, i will leave it as is for now
I am trying to use the flight mode now but whenever i try to add the return home function and the kill switch i am getting mag sensors inconsistent and i have to reset all settings and try from begining

#6

I’m not sure if I understand correctly. When you say “the flight mode”, which mode is it? Stabilised? Position?
Do you have mag inconsistent warning before or during flight?
Could you maybe share a log and a few pictures of the setup?

1 Like
#7

thank you for your support, appreciated
I will upload pics and the log file once i am back home,

thank you

#8

Kindly find the attached setup and if you need any clarification i can do it and below is the download link for the log files

the inconsistent is before flight while preflight checking
thank you
https://drive.google.com/open?id=13X2qgUH8Fj-zlF96Xml3Hah2alptc6cp

#9

@Mohamad_Hariri Hi, thanks for the picture and the log. However I can’t access your drive. Could you upload the log file(s) to https://logs.px4.io/ and share the link here?
Did you do a compass calibration (followed by a reboot) on the complete setup? Does the heading drift in the QGC compass display?

#10

https://review.px4.io/plot_app?log=ccdda47c-bf40-4ae3-a869-b8d8ad47aab8

hello, kindly find the following link i uploaded the latest log file,
yes i did the compass calibration and reboot after the calibration
for the heading drift i didnt understand what do u mean, but if i rotate the quad i have a live feed back at the QGC that the drone is rotating,
knowing that the gyroscopic meter in the QGC while having this error will show that the drone is not leveled even when its on the ground and if i try to recalibrate i will not be able on position will get error so the solution is to reset the settings and start from beginning

the last time i got this error i left the drone disconnect the battery and when i came the next day it was working fine without doing any thing :slight_smile:

one more question if i want to connect a servo to the drone, do i have to connect it to FMU on the power board? is there any setting i have to do ?
thank you for yur support

#11

The mag problem is king of weird. I’ll think about it.

About the servo, you can connect a servo to the output 5 or/and 6 of IO. The mixer already support it: https://github.com/PX4/Firmware/blob/master/ROMFS/px4fmu_common/mixers/quad_x.main.mix and https://dev.px4.io/en/concept/mixing.html (use AUX1/2).
If you want to connect it to the FMU port, you would have to add an auxiliary mixer with the following lines:

M: 1
S: 3 5  10000  10000      0 -10000  10000
#12

Hello @Mohamad_Hariri !
I am planning to use the same ESC motor combo you have used. I wanted to get your feedback regarding the performance of the system before I ordered the components. Are you using 800 kV motors ? What are your battery specs ?
Thanks much !

#13

Hello Vrinda, i am sorry for the late reply,
Yes i am using the 800 kv motors from dji with 3500 3 s battery
I was not able to test the drone yet i have not enough time for the project and the pixhawk is not making it any easy
Once i do the outdoor testing i will inform u

#14

Thanks much @Mohamad_Hariri !

#15

@bresch

I read your first reply. I have several questions.

  1. Can I use FMU port instead of I/O port of the PDB to receive signal from FC without setting up any other parameters?
  2. You said that 2nd solution disables I/O co-processor, but what exactly does I/O processor do? Is it fine to disable the [quote=“bresch, post:2, topic:8038”]
    SYS_USE_IO
    [/quote]

parameter in hexacopter?

#16

@hslyu
IO is used to have more PWM ports and to be able to recover manually a plane if FMU crashes.
For a hex, it’s totally reasonable to disable IO if you don’t need additional outputs. As an example, the PixRacer autopilot has no IO processor and it’s perfectly fine.

#17

Hello !
I have F450 frame and am following your build. The following are my queries:

  1. I wanted to know if PWR 2 is required ? According to the documentation I can use just one power brick of Pixhawk 4.

  2. Additionally I will connect the ESC signal wires to the M pads on PDB (of Pixhawk 4) as discussed in this post. However then, are the connections to I/O PWM IN and FMU PWM IN at PDB required ?

Thank you for helping me on this, this post is very useful !

#18

Hi @Vrinda ,

  1. PWR 2 is useful if PWR 1 dies, it’s really rare and it’s up to you to decide if your autopilot needs power redundancy (it never hurts but it’s not mandatory).

  2. The M pads of the PDB are connected to the IO PWM pins; you need to connect the IO cable to get the signal from the Pixhawk4

Good luck!

1 Like
#19

Got it ! Thanks much @bresch ! I found this post very useful.