Pixhawk 6X cannot disable safety switch

Dear All

I am using a pixhawk 6x mini. I have set COM_PREARM_MODE=0 (disabled) and CBRK_IO_SAFETY=22027 (I/O safety circuit breaker engaged). BUT when I want to calibrate the ESC keep having “cannot disable the safety switch” and thus cannot move forward.
After reading the px4 docs I do not see any other parameter to set.
Can you tell me, please, if there is something else that can prevent me to arm/calibrate the ESC?

On the Mavlink console, if I enter : listener safety got the following:

safety_switch_available : True
safety_off: True

Looks like that the safety is off but i do not understand the meaning of this safety_switch_available…

I noticed that while the ACT Led is blinking blue, normal, but the B/E led is orange, is it the normal ?
Thank you for your support

This sounds a bit broken :confused:.

Have you considered setting SYS_USE_IO=0 and just using the FMU outputs and not using the safety switch at all?

@JulianOes thank you for your message. Actually I am using dshot for the ESC (dshot_config= dshot600) and I have SYS_USE_IO = 0 already.
But I got “cannot disable the safety switch”. Now if I set SYS_USE_IO = 1, I do not get this message anymore so I can calibrate the EScs but I cannot spin the motor with the motor sliders… yes one problem at a time so I have to investigate (I have also a problem to retrieve MAVROS msgs on TELEM1 - this 6x board is a hurdle)

This is a side question, but do you know any website where it is possible to purchase a used pixhawk 4 mini? or can you tell me where I can post this question on that site?

Tricky, I don’t know what’s up with the safety switch thing. Is this with v1.13? Have you tried with v1.14 beta?

You probably need this fix:

Unfortunately it’s not backported to v1.13 yet.

I know they are scarce. I guess ask in the forum or Discord.

Regarding Pixhawk 4s, maybe ask @Vincentpoont2.

The Pixhawk 4 Mini has been discontinued, maybe you will have some luck with some user willing to sell it if they have one laying around, but there is no official marketplace for this sort of stuff.

@JulianOes thank you for the link regarding the uart - I came to the same conclusion and it works fine now
However, I cannot spin the motors yet - I am puzzled here
As I mentioned with SYS_USE_IO = 0 I have the message “cannot disable safety switch”. Beside, the B/E led is orange blinking.
If SYS_USE_IO = 1 I do not have the message anymore and the B/E led is not blinking anymore after reboot.
But if I connect the ESC to the FMU PWM OUT - if I follow the instruction (DShot ESCs | PX4 User Guide) the motors do not spin… so far I do not any clue.
@Vincentpoont2 thank you for your message.

@FaboNo Here is wiring guide. ESCs should default connect to “I/O PWM OUT” unless you have it configured differently. Can you try that?

MAIN outputs in PX4 firmware map to I/O PWM OUT port of Pixhawk 6X
AUX outputs map to FMU PWM OUT of Pixhawk 6X .

For example, MAIN1 maps to IO_CH1 pin of I/O PWM OUT and AUX1 maps to FMU_CH1 pin of FMU PWM OUT .


@Vincentpoont2 Actually I have 2 “ESC connectors” along with the Pixhawk 6x - see pic below:

When I looked at the pin out, only GND and +3.3v are provided for the eight channels. The question is do I have to provide +5v as well?
Thank you very much for your support

@FaboNo The ESC needs to be powered.

What ESC and frame are you using? Also make sure your signal and negative is on the correct places. The signal is on top, negative is at the bottom.

@Vincentpoont2 I am using ESC F45A V2 3-6S - T-Motor
So I will purchase a BEC 5V to power these “ESC connectors”