Not connecting to QGroundControl for initial setup

Good evening,

I’m looking forward to building my plane, but apparently getting to the initial setup has thrown me a curve. I am trying to connect a Cube Black Pixhawk 2.1 to my Windows 10 laptop, the flight controller flashes an orange light then goes steady. Qgroundcontrol Firmware page shows no options for firmware. I was able to get connected to Mission Planner, but I would prefer to run PX4 / QGroundControl.

Thanks for any hints.

How does that look? I’m not sure I understand. Maybe you can share a screenshot.

When you first open QGC and click on the Firmware tab, you should see this:


Then when you connect the Pixhawk via USB, you should see this:


If it didn’t activate that windown, check your Device Manager to make sure you have PX4 FMU showing up as one of the Ports. If not, you may have to uninstall and reinstall QGC.

image
Good luck.

Good afternoon,

I will give the re-install a try, maybe on my older windows PC and see how it goes. For now, I get the first screen, but not the second. I am also going to look into Windows 10 Security settings for apps, I will follow up with results.

Thanks!

Still no joy. I even tried installing Ardupilot through Mission Planner, and that flashed fine. The Pixhawk is now talking to Qgroundcontrol, but I am still trying to flash the board with PX4 instead.

The firmware tab asks me to unplug the board, so after that I follow the Plug in prompt. It gives me the upgrade option, but then gives me the following error code:

My device manager does show the Pixhawk on COM9.

So, I’m a little stuck unless I run with Mission Planner. Any other tips would be appreciated.

Thanks again,

-Matt.

Does it specify: PX4 FMU (COM9) ? If not, try a different USB cable or uninstall QGC, reboot then reinstall it.

Until you get a second window as above when you plug in the Pixhawk, you won’t be able to upload any firmware to it.

Good luck.

Great start to my reintroduction to PixHawk, lol… PX4 FMU is no longer showing on the COM port, I reinstalled QGroundControl and am using a new USB cable. It does give me the second window, but then goes to the screen shot I located in the previous post. Now I want to wipe ArduPilot off the PixHawk and start fresh, but I can’t seem to get that done either. Oh well, I’ll keep trying and hopefully I can pull something together.

I just saw this in another thread and I don’t know if it’ll work but at this point, why not.

  • Open QGC and click the Firmware tab.
  • Press and hold the safety switch and while holding it down, plug in the USB
  • Does it give you the 2nd window to choose what Stack to load?

Good luck.

I tried that, thanks for the hint! Still no go, firmware load screen comes up and gives me upgrade cancelled, then heads over to the Vehicle setup wizard. It’s also not showing on the Device Manager. Pretty frustrating…!

Before%20the%20Plug%20In|690x454

It was fun trying to pin the safety down as well as screen capture before this window disappeared to the Vehicle Setup…

Anyways, thanks for trying to help. I have switched cables, reinstalled several times now, and still a no go. It looks like I’ll be able to run Mission Planner if it really comes down to it.

Thanks again for looking.

Can you try choosing the PX4 1.9.0 Stable?

Good luck.

Good evening,

I tried to select it, but the firmware update screen still locks me out for the most part. See screenshots above, still the same result.

The update window keeps giving me the update fail message, so it will not let me select and update firmware. I’m about at wit’s end with it, maybe sticking with Ardupilot is my solution. I was looking forward to trying something new though.

As far as troubleshooting goes, I tried the following:
-Different cable
Uninstall / reinstall Qgroundcontrol
-Uploading through Mission Planner - this put Ardupilot on the board, now detectable by QGroundControl - still locked out of firmware update.
-Windows 7 on an older machine
-Windows 10 on the new computer
-Press and hold safety button on GPS head when plugging in.
-Shutting off firewalls
-Different SD card in the Pixhawk 2.1

I’m out of ideas at this point, other than use mission planner for firmware updates and run Ardupilot.

@JulianOes @DonLakeFlyer @dagar Maybe one of you can chime in. This doesn’t make much sense.

Thanks.

@Resourceful Create an issue in QGC github and we can continue to debug there.