Help debugging firmware update through QGC on Windows using USB

#1

When trying to update Pixhawk mini firmware, I am seeing the following message in QGC v3.2.7:

This is the only message I get when in the Firmware screen. It never prompts for updating the firmware. I tried removing and re-installing QGC twice, but no change. It seems to be stuck on this message, hence there is no chance to update the firmware.

This message is there regardless whether the Pixhawk is connected or not. I tried launching QGC by itself with no connections to the Pixhawk, and with it connected. No change.

This is the screen I never see.

Any idea what the problem is?

#2

1、Did you have try another usb cable?please try another again.

2、if you pc has another usb devices,please unplug them.

#3

I tried using different USB cables,and removed all other USB connections from the PC. Nothing changed. I’m beginning to think the Pixhawk is not communicating with the PC for purposes of updating the firmware.

However, when connected by USB directly to QGC, the flight control screen does show compass motions, meaning that there is communication with the Pixhawk.

With this discrepancy under the same conditions, what could be wrong? Is the Pixhawk damaged? Is there any other test to determine the problem?

#4

Do you always have the list of tabs on the left below “Firmware” (Airframe, Radio, etc)? Those only show up once QGC has received parameters from the flight controller.

When your pixhawk is disconnected and powered off, what do you see in the summary tab?
Do you see a “Communication Lost” message where the PX4 logo is in your first screen shot?

However, when connected by USB directly to QGC, the flight control screen does show compass motions

What do you mean by connected directly? How are you trying to connect to it?

#5

When the Pixhawk is connected to QGC using USB, I can see the entire setup menu:
Summary
Firmware - this says to unplug the PH from USB
Radio
Sensors
Flight modes



All my sensors are calibrated (green). QGC shows the position and attitude of the Pixhawk. Everything looks good at this point.

When I disconnect the USB cable I loose connection, and the setup menu now shows only Summary and Firmware tabs. There is nothing in the Summary except the statement “vehicle settings and info will display after connecting your vehicle. Click Firmware on the left to upgrade your vehicle.”

When I click Firmware I get the message
“QGroundControl can upgrade the firmware on Pixhawk devices, SiK Radios and PX4 Flow Smart Cameras.
All QGroundControl connections to vehicles must be disconnected prior to firmware upgrade.
Please unplug your Pixhawk and/or Radio from USB.”

At this point I already have the Pixhawk unplugged!!! It does not prompt me to plug it in to do the firmware update. When I plug it in I’m now back where I started from. I never see the menu for selecting a device to update.

I hope this makes it clearer.

Thanks for responding so quickly.

#6

Yes that makes it clearer.

And when you start QGC with no Pixhawks connected via USB (and no other ones powered that have a WIFI telemetry link, no simulation running) you also see the “please unplug” message on the Firmware tab?

What I would try next is install a daily build: https://docs.qgroundcontrol.com/en/releases/daily_builds.html

And in Application settings (the purple QGC logo in the top left corner) > General > “AutoConnect the following devices”: deselect all but Pixhawk, then restart QGC.

#7

Nicolas: I appreciate your help. Yes, when I launch QGC without any Pixhawk powered on and no external device plugged into my PC, the Firmware tab says exactly that:

QGroundControl can upgrade the firmware on Pixhawk devices, SiK Radios and PX4 Flow Smart Cameras.
All QGroundControl connections to vehicles must be disconnected prior to firmware upgrade.
Please unplug your Pixhawk and/or Radio from USB.

The funny thing is that when I installed this version of QGC over a month ago, I was able to do the firmware update without a hiccup. This new behavior just started, but it was not there before.

I tried your 2nd suggestion, but there was no change. I’ll try installing the daily build next.

Thank you. Joe

#8

I’m having the exact same problem. I have a Mac and a PC. It’s giving me the same problem on both. Like you said it worked a month ago. If you come up with a solution can you please share it?

#9

Nicolas:
I installed the daily build but no change. This is the strangest thing.

captaindave, you are having the same problem, so I wonder how many others are having it?

I’ll keep working on it, and wil let you know if I find a solution.

Joe

#10

I’m out of ideas.

Maybe @DonLakeFlyer can help?

#11

QGC thinks you have something plugged in by USB which is a board. Most likely some sort of FTDI device. Make sure you have no other thing plugged in via USB. If that still doesn’t work enter this problem as a QGC GitHub issue and then we can work on more detailed debugging there

#12

Here’s a Hail Mary… download Revo Uninstaller and choose Advanced to uninstall QGC. Make sure you Select All and Delete all found entries and registry. Reboot the PC then install the QGC Stable release and see if that resolves your issue.

Good luck.

1 Like
#13

Any updates on this? I’ve tried all of the advice above with no luck. I’m running MacOS Mojave 10.14.2 and downloaded the latest QGroundControl. Because the new MacBook pro’s don’t have a USB port I’m using an external one - is this the issue? Any advice is greatly appreciated!