Unable to connect to MAVLink Console with Orange Cube

I’m new to PX4 and QGroundControl, and I’m trying to get my PX4 with Orange Cube to detect two distance sensors (Benewake TFMini and VL53L1X Lidar) through QGroundControl, but they’re not being detected. When QGroundControl starts up, it says “Distance Sensor 0 missing”. I’m under the impression that these can be added via MAVLink Console; however, I’m unable to use the console. It’s just a blank “>” and typing commands “?”, etc. does not do anything.
I’ve tried suggestions from Mavlink console does not appear to be working · Issue #19831 · PX4/PX4-Autopilot · GitHub with no luck. Please guide me to information about how to connect these sensors or how to get MAVLink Console working.


What is the firmware version, QGC version that you have installed on the CUBE and GCS . What is the GCS model you are using here .

Thank you very much for your knowledge and assistance!
The QGC version: 4.2.3
The Flight stack: PX4 Pro Stable release v 1.13.1
The Orange Cube: Hex / ProfiCNC connected to bootloader:
Board ID: 140
Flash Size: 1966080
Standard ADS-B base
I hope that I have adequately informed you of the information you requested.
Thank you, again!

Can you type “param show” and advice what happens on the console

When “param show” is typed in mavlink console the cursor returns back to the > and remains blank.
If it matters, the UAV firmware is generic hexarotar x.

However, when I type “param show” with the " " marks included the "param show " remains with the cursor at the end.

… …what about param

no need for any quotes…please try what happens when you type param

OK…i guess you are correct…I just replicated the same issue on a Px4-SITL - QGC simulation environment…

However it does work with me on my CUBE Orange - Herelink - Px4 (v.1.12…) combination …May be a customized version of QGC may be required for Mavlink console to work or the px4 version may be required to be downgraded…

Thank you, and congratulations on your ability to replicate this issue.

What would you recommend and how would a customized version of QGC be obtained?
I would be willing to proceed with a downgrading of px4 version from v 4.2.3 to another version, however I would consider it prudent inquire your opinion on which version you would suggest.

Better downgrade the px4 version to 1.12.xx stable release .
The qgc version is a customized version on my Herelink radio telemetry.
For QGC version, try an earlier stable release than the one installed…

Thankyou for your prompt reply. I will try to downgrade to an earlier version. hopefully, that would allow me to configure the two distance sensors without generating some other obstacle.
Is there any chance that this issue might be corrected in and upcoming version?

Also did you try the following step.

Create folder etc on sd card from your Cube, create file extras.txt inside etc folder (if you don’t have it already for other purpose), then just add line mavlink start -d /dev/ttyACM0 to that file, save and put sd card back in Cube. It should start working now.

Thank you for your additional information. This option seems to be a better option, especially as I am having some difficulty in utilizing an older version. I have found v 1.2 .3 but can’t seem to get the qgroundcontrol installer to run it. I now have v4.2.4 even though I have uninstalled it.

I will attempt to add the files to the SD card.

Thank you for your continued help.

I added the text to the SD card as you requested, however, unfortunately mavlink console is still not working.

Do you have any other suggestions? I’m sorry to continue to request your further assistance, and greatly appreciate all of your help and guidance.

How are you connected to the autopilot with QGC …Please describe the complete hardware setup or send me a photo of the setup of the hardware. Dont miss out a single hardware
Also send me a pic of the device manager settings of your pc or laptop where it detects your UAV com port

The hardware is: orange cube usb directly to computer usb via data transfer cable. See 3 pictures.

The device manager is local computer ( desktop bpqppj67 to comport usb serial device ( COM8).

I hope you are able to view.
Thank you.

what i understand from your setup is that the cube driver is not correct. Strangely there is no yellow mark on the device manager either. When you connect the cube to the computer, you should see cube orange comx in the device manager. Strongly recommend to troubleshoot from here rather than changing your qgc or px4 versions
you could update the serial usb driver and see what happens

Yes. I see the deficiency in the device manager.
I am unable to locate an updated orange cube driver for windows 10 that is not free.
The sites all expect a payment.
I will continue my search, however, if you could suggest a download site, I would be very grateful.

In my continued search for a driver, I have attempted to contact the manufacturer however the email address given was incorrect and mail undeliverable.