PX4 not connecting to QGC or MP

Well this is a FIRST! …
Have used QGC in the past with several other PixHawks without any problems …

I received my new PX4 in today and it will not connect at all … I tried Mission Planner and could not even see a comport listed for the PX4 …

Is there something special with the PX4 I don’t know about?

Any info would be appreciated


Hello TexAcoon
I suppose you use USB Connector ?
What is happen after this (on your computer know the USB port, the led on Pixhawk give you some information) ?

Does something show up in the Device Manager (on Windows) or using dmesg or lsusb on Linux?

Hi Serge,
With the PX4 blank I am having to load the programming via J-Link debugger …
With the PX4 plugged in usb I’m not getting anything showing on my usb port on my computer BUT I see the J-link connection … When I try to run the prgram from JLink commander it does not connect to device… I believe thats because the PX4 has something wrong with it … OR there again it may be something else thats not working correctly (Hey! could be the operator LOL!)

Hi JulianOes,
I run Windows 10 … nothing shows up in the Device Manager for the PX4 …

This sounds like a hardware issue to me.

Since I wrote this post … I have tried several options to get it to work … I still do not get a connection to the PX4 … This is a bit difficult to determine when you have four components you are having to work through and not sure which one may be bad …

  • Have you tried using a different USB cable?
  • Do you have the latest version of QGC?
  • Uninstall QGC, reboot the PC then reinstall it.
  • Open Device Manager and click the plus sign of Ports (COM & LPT).
  • Plug in the Pixhawk and see if the PX4 FMU shows up. If it does, open QGC and it should be able to read it.
  • If it doesn’t, uninstall your J-Link debugger, reboot then try again.

Good luck.

Found my problem … My issue was with uploading program using the J-Link / Debugger/ PC wiring issue. The wires (connectors) that connects between the debugger and PX4 connection was bad. I ended up using a meter to check from connector to connector point until I found the red wire was not showing continuity … I worked the wire to see if it would make up and sure enough it did … Had to tape the wire to the table top and positon the PX4 around running J-LINK Commander until it uploaded the program to the PX4 … WHOA! What a pain in the A$$ that was! …