Help; Parameters menu not showing in QGC or MP when connected by Mavlink

I am working on 3DR Pixhawk.
I am new to QGC, Have downloaded the latest version of GGC 3.4.1 and flashed the stable firmware for Helicopters. All seems to work fine when connected by the usb cable. In the setup menu all the settings and parameters are shown. But if i connect from the Mavlink, i do not get to see any settings or parameters. It only gives me the option of firmware update and also gives me an error message stating “Vehicle1 did not respond to request of parameters. This will cause QGC to be unable to display its full user interface.” When i move the pixhawk i am able to see the artificial horizon move in the QGC.

I have tried both PX4 as well as ardupilot firmware, both are the same problem. I have tried reflashing the firmware many times, also i have flashed the firmware to a fixedwing but the problem persists.

Is there any driver issue? or it the firmware issue? How do i sort this problem out? Please see screen shots of the error

Thanks in advance.

  • What telemetry radios are you using?
  • Is your ground module connecting to the air module by showing a solid green or blue LED light?
  • Is your ground module showing up in your Device Manager? If it does, what’s the name of the Port?

Good luck.

Hi, thanks for your reply;

  1. I tried using the original 3dr 433mhz radios as well as 3dr klone 915mhz radios too.
  2. The pixhawk is connecting from the mavlink, i can tell that cause when i move the pixhawk the pitch and roll changes in the QGCS except for the parameters menu showing up. I have solid green lights on both the radios and when interacting the orange lights blink in both while the green stays on.
  3. I’m posting a screen shot of my device manager for USBs.

Also, i did go to the Mavlink inspector and i see that its refreshing. Please see screen shot of this too.
I even tried connecting to Mission planner, soon after it connects and while it says “Getting Params” it just stays there in the same thing but dosent go further at all. I’m posting a screen shot of this too.


  • Try separating the radios farther apart from each other. Maybe, somehow the air module is swamping the ground module.
  • Try changing the orientation of the ground antenna. If it’s vertical, lay down; if it’s pointed to the left, try pointing to the right.
  • Try swapping the radio antennas with each other.
  • Try updating the firmware of both radios.

By the way, this was what I was referring to in the Device Manager:

And when you click on Properties, this is what it shows for the Driver:

Good luck.


Heres the device manager’s screen. Also, How do you update firmwares of radios? Mine dosent say 3D Robotics or Px4!!!


Updated both my telemetry radios and now they dont recognise each other. The green lights been blinking ever since i updated the firmware… Am i missing something? I updated the 3DR radios. Now scared to do for the 915mhz…

I think you have the wrong driver. This is what I have. You can download and update your driver here.

Good luck.

Oh oh… I use the 3DR Sik Radio Config Tool. I wonder if it didn’t correctly copy the configuration from the ground module to the air module.

If that’s the case, what I did was use QGroundControl from the Firmware tab to update both. You’ll need to wire up and use the FTDI adapter to connect the air module to QGC.

Good luck.