USB Connect Failure to Pixracer (2off) and Pixhawk. Can't talk to any

#1

I’ve been scratching my head for 4-5 months asking why I can’t connect to any of three PX4 flight controllers - two Pixhawk Racers or my big brother PX4 controller.No matter what ground control software e.g. Mission Planner, ArduPilot, QGround Control, no connection is made via any USB port I plug into. I use Win 7, and have wiped this and re-installed in desperation, to no avail! I’ve been tempted to buy another Racer for elimination purposes, but I don’t have a use for one, and they are quite expensive.

The Racers sit with a yellow LED ON and a Blue/Pink flashing LED (about once per second)
What should I see by way of a driver in Device Manager? Watching Device Manager when starting e.g. Mission Planner. I see no driver being loaded on the fly. Is that to be expected? If so, **then any driver should be there already, so what heading is it under, and what name does it have?.I have a dim recollection of seeing a web page showing a relevant USB driver somewhere in the middle of Device Manager’s display (?) I’. focused in on this being the seat of my problem?

Someone out there can end my misery, and bask in my praise and thanks, hopefully!

1 Like
#2
  • Change the USB cable.
  • Download and try the CP210x driver for Windows 7.

Good luck.

#3

Changed USB cable. Downloaded & installed suggested driver. It showsup as Legacy FMU (COM3) in device manager. But I get… “Error on link\.\COM3 Could not create port. The system cannotfind the file specified” when I start QGroundControl.
Interested to see that it remained showing in device manager when the program closed. It may not be the right driver, but NO drivers other than COM1 and LPT1 have ever been seen previously, and COM1 does not do the trick… The above suggests I should have had a permanent entry beforehand in device manager.
I’ll need to review how (if possible) I can add other COM ports,.COM2&3…or find the right driver. I also wonder if I can connect via WiFi as I have the little WiFi clip on board that came with the Pixracer(s). That could take me some time to implement, I’ve reinstalled QGroundControl, etc, several times and never see a newly loaded driver. Aaaargh!

DO YOU SEE A SPECIFIC USB DRIVER LOADED IN DEVICE MANAGER??
Thanks a lot for repying.

#4
  • Do you have any Unknown Device showing in the Device Manager when the PH is plugged in?
  • Do hear your PC respond with the usual tone/sound when a USB device is plugged in?
  • Have you tried plugging it in the other USB ports?

These should be what you’d see in Device Manager (except maybe for the COM Port number):



I don’t know if this will work but try to install this PX4FMU.INF and see if it works for you.

Good luck.

#5

Specifc USB driver when controller plugged in is: LEGACY FMU (COM3). (Manuf- Hex Technology)Tone heard.Other USB ports/cables tried - yes. Update Driver says I have the latest, but did I get the right one - not as your example.usbser.sys not in System32 (or System)
Looking for PX4 FMU.inf takes me to git hub- scary! I see the px4fmu.inf as a text file. Loaded into Notepad. Deleted LEGACY FMU driver.

While trying to install this .inf file via Device Manager, I highlighted COM1 and asked for a scan for new devices. Thinking to instruct “add new”… PX4 FMU (COM3) appeared as a new entry. [My Flight Controller was attached]. Manuf 3D Robotics!!
I have a good feeling about your helpful input. (where are you located. I’m Scotland).
I note your posting re offboard mode.
Feels a bit like “answer one question and get three more for your efforts”. But now I seem to have a few options
+Investigate adding COM ports or the consequence of changing COM1 to be COM3
+Offboard mode possibilities
+WiFi connection possibilities
+Understand what access GitHub has to offer in “developer mode”) [Oh Boy!]. i.e.get under the bonnet/hood

Typing usbser in Start Menu search brings up “PX4FMU Driver” on my desktop! Sort that later!
Busy for a few days but will report back.

#6

After a long period of failure, I found a solution. I located a PX4 Driver .msi file. I ran this in Safe Mode (modified to allow installations), and got legacy FMU (com3). This works OK. I found .inf drivers but never got these to work despite searching online for “how to” - eg via Explorer right click - “not allowed”.

Anyone needs that .msi file, then let me know. At least it gets you going. Update Driver did not find anything better.