Compass 1 Uncalibrated Error

Hello I am having an issue with my Pixhawk 6C. The error that I am getting is Preflight Fail: Compass 1 uncalibrated. The both GPS modules i tried are consistently blinking red as well. I already calibrated the compass outside as well as the accelerometer. I tried using a Holybro M8N GPS module connected into the GPS1 slot and a Here3 connected to the CAN1 slot still the same problem. Does anyone have any ideas on how to fix the issue?

Airframe: Generic Quadcopter
Firmware: PX4 Custom Build from Master Branch (v1.13.0 beta)
Date: September 27, 2022
Daily QGC Build

Thank you,
Aaron Porter

I found a work around to my problem, after each boot up I have to recalibrate the compass again for some reason and that fixed the issue. Please let me know if there is a parameter that is needs to be set. Recalibrating the compass after each use is not ideal.

Thank you again,
Aaron Porter

Is this master installed with QGC? Or you pulled it yourself?

1 Like

Thank you, Originally I had it on a build that I pulled from Github. After your question, I tested the master build from QGC and it worked fine without needing to recalibrate the GPS compass every start up.

Out of Curiousity, do you know why the build on Github and the build on QGC are different?

Thank you again

per @mwbb : It might be that CI tests have to pass before released to QGC’s master. As compared to Github where once merged into master it is just there

1 Like

As an update, I tried to recreate the Compass 1 Uncalibrated Error yesterday by reflashing the Pixhawk 6C with the cloned firmware that I compiled from main. To get the log files, and post them here. Unfortunately, I was not able to recreate the error, so I am not sure if it was a fluke error on my part.