Pixhawk Mini Compass Calibration Not Working?


I’ve been building a hexacopter with the Tarot 680Pro frame and a Pixhawk Mini. Everything has worked pretty well, and i managed to calibrate and fully setup the pixhawk before I attached it to the frame. However, now that I have the pixhawk on the frame, trying to re-calibrate the Compass fails with an error, “no matching uORB devid”.

I couldn’t find anyone that had the same problem as me, and this happened both with and without the external compass and GPS plugged in. Anyone know how I could try to fix this? I tried resetting all the parameters also and it did nothing.


1 Like

That is some sort of firmware problem. You should ask in a firmware forum.

well i reflashed the firmware a few times and eventually it worked lol

I am having a very similar probblem calibrating my compass. Im using an external gps/compass from 3dr. What version of px4 firmware are you using? and could you provide any more details about how you got it working?

I had the same issue. Here is my steps to get the compass calibrated:

  1. Firmware upgrade using QGC from master 891b0adb4920b9e3d1f74ef369c3c850633a8cd1
  2. I selected the option for PX4 1.6.3 stable
  3. After installation it reported 1.6.1dev (I noticed the URL during download was something like px4-travis … stable … px4fmu-v2default)
  4. Calibrate compass with USB connected, no issues
  5. Reconnect using telemetry radio
  6. Calibrate compass fails with ‘no matching uORB devid’
  7. Download PX4 1.6.3 from GitHub
  8. Connect USB, perform firmware upgrade, choose downloaded firmware px4fmu-v2_default.px4 (in firmware selection dialog, click Advanced, and ‘choose file’ from drop down, then click OK and you’ll be prompted for the file)
  9. After upgrade version reads 1.6.3
  10. Reconnect with telemetry radio
  11. Calibrate compass works now!

It seems the issue could be the stable firmware on px4-travis is incorrect ??