Camera Trigger

#1

I have a standard VTOL and i’m planning to use it with camera. I’m using Pixhawk Cube2. I made all the connections regarding to Standard VTOL airframe references but when the camera is enabled, pusher motor cannot get any signal. I tried to change TRIG_PINS parameter to 6 only but it didn’t work.

Can someone help understand why this is not working? Thank you!

1 Like
#2

If that the trigger of the camera is not working properly then you should do the troubleshooting from the help to know the entire process from the help of the Epson tech support for that idea to recover those things.

#3

. Camera trigger default pins are AUX5-AUX6. I changed to TRIG_PINS to 6 and connected to throttle(pusher motor) AUX5 which is default for the standard VTOL configuration. Camera trigger is working fine but when enabled pusher motor does not work. The pusher motor works only when the camera disabled.

#4

This was pulled from the configuration page for the camera triggering. Pins 5 and 6 are grouped together and can only be used for either camera triggering or actuator control.

“”"""""""
Trigger Hardware Configuration

You can choose which AUX pins to use for triggering using the TRIG_PINS parameter. The default is 56, which means that trigger is enabled on AUX 5 and AUX 6.
With TRIG_PINS set to its default value of 56, you can use the AUX pins 1, 2, 3 and 4 as actuator outputs (for servos/ESCs). Due to the way the hardware timers are handled (1234 are 56 are 2 different groups handled by 2 timers), this is the ONLY combination which allows the simultaneous usage of camera trigger and FMU actuator outputs. DO NOT CHANGE THE DEFAULT VALUE OF TRIG_PINS IF YOU NEED ACTUATOR OUTPUTS.
“”"""""

https://docs.px4.io/en/peripherals/camera.html

#5

So there is no way i can use camera trigger with VTOL configuration…

#6

I have not used the pixhawk cube before but I have made vtol aircraft that have used up all 8 mains and 3 of the aux’s of previous pixhawks. You should re-map the throttle (pusher motor) from Aux 5 to some other number. You can do this via the aircraft init.d and mixers files located within the ROMFS folder within the Firmware folder. You can either re-compile the firmware, or place the changed mixer files on the pixhawk sd card. If placing the changed mixer file on the sd card, you have to create a folder called “etc” then another called “mixers” inside of that.

https://dev.px4.io/en/concept/mixing.html

#7

If the issue is hardware related, chances are that this will fix the Epson error code 0xf1 problem and you may be able to use it normally.