How to enable camera (TRIG_MODE)?

I’m a bit stumped by how to enable Camera on PX4. On ArduPilot, camera parameters are always transmitted at boot, so QGC always shows the Camera in the setup/configuration screen. But it appears PX4 does not transmit the necessary TRIG_MODE parameter, so QGC does not display camera options.

Does anyone know how to get PX4 to turn on Camera params?

1 Like

I think almost everything is well explained here: https://docs.px4.io/v1.9.0/en/peripherals/camera.html
Take in mind that after EVERY parameters change, you need a reboot to actualy set the parameter, so go to the Analyze tab (the one with the folded sheet and the magnifying glass), then Mavlink console, write “reboot” without quotes in the nsh shell (bottom of QGC interface) and then hit enter.

You can also change camera parameter in going in Vehicle Setup tab (the one with the gears) and then to the Camera settings (the second last).

Thanks, but because the necessary TRIG_MODE is not transmitted at boot, neither the camera options nor the parameters you pointed to are listed. This is what I get in QGC (no camera option):

Try using

param set TRIG_MODE 1

in mavlink shell

Problem solved. It turns out that these params are not supported in FMUv2 (original Pixhawk, Pixhawk Mini) due to memory constraints. Basically in the current version of PX4 there is no camera support for those older autopilots. So I upgraded to a Pixhawk 4 and now everything works as expected.

Thanks to Hamish for getting to the bottom of this.

4 Likes

Note that it is possible to have it on the FMUv2 but you would have to disable some unused modules and drivers to enable the camera.

It may be possible that your FCs have the 2MB chip but has a version 4 bootloader (older one) which is only recognized as FMUv2. By updating the bootloader, it’ll be recognized as an FMUv3 and load the “full boat” version. I’ve done this on every 2.4.6 Pixhawks.

Good luck.