Version 1.13.0 : Camera Trigger PWM does not working

I want to working Camera Trigger & Capture

but does not woring…

FC : CUAV V5+
TRIG_MODE 4 (distance - survey mode)
TRIG_INTERFACE 4 (IR PWM)
TRIG_PINS: 6

I think that AUX6 pin output pwm 1500

1500 is default setting value

and if i want shutter with GCS(Qgroundcontrol), AUX 6 pin output 1900(default)

but AUX 6 don’t output anything value

I try to any another FC

example : CUAV V5 Nano, Orange Cube

Evrything does not working

Are there any other parameters that need to be modified?

if not

Are there any other parameters to activate?

@GriTRini I think there are two things here - Is the camera trigger not working or the camera capture?

How are you testing the interface?
Can you share the log of it not working?

https://drive.google.com/file/d/1Fr87jMMGi1MNZH3ZyyzSWWFzzbpauEcb/view?usp=sharing

I do not upload log file
so i share google drive url

Thank you~!

I does not working camera trigger

I setting TRIG_PINS: 6

and I connected the AUX6 and the oscilloscope to see how the signal came from the AUX6.

I test Camera shutter response with pwm.

Pwm is setting RC AUX2.

Camera’s response is normal.

but if i change camera trigger, did not working and didn’t output pwm.

What’s the problem??

I know problem

Problem is airframe.

I select standard vtol. but this is not working

Hi @GriTRini @Jaeyoung-Lim , have you solved this issue yet? I faced a problem with the camera trigger too. Firmware v1.13.1, Airframe standard vtol, FC: pixhawk 4 and cube orange. Trigger did not work for both GPIO and Seagull PWM. I have experience setting up these before using firmware 1.12.3 However, everything works fine, so I think this is firmware/software bug

@saengphet Please provide either a log or more information what you have tried, how it is failing.

Just stating that it is not working is not enough information to diagnose what the problem is

In the Linux program (git clone GitHub - PX4/PX4-Autopilot: PX4 Autopilot Software --recursive), type the command into the terminal and download it (bash./PX4-Autopilot/Tools/setup/ubuntu).sh) Type this command and then make build according to your FC. For example, type (make px4_fmu-v5_default) if pixhawk 4 or (make px4_fmu-v3_default) if pixhawk 2 orange

If you don’t succeed, tell me and I’ll share the file.

@GriTRini Have you tried configuring the camera trigger?

Yes, I have but not working so i changed firmware and solved

In the Linux program (git clone GitHub - PX4/PX4-Autopilot: PX4 Autopilot Software --recursive), type the command into the terminal and download it (bash./PX4-Autopilot/Tools/setup/ubuntu).sh) Type this command and then make build according to your FC. For example, type (make px4_fmu-v5_default) if pixhawk 4 or (make px4_fmu-v3_default) if pixhawk 2 orange

@GriTRini So it is working now? How did you configure your camera trigger? This information is not included in the instructions you have provided

Firmware version: v1.12.3 and v1.13.1

Result
v1.12.3: PASSED ALL
v1.13.1: FAILED ALL

Test Conditions
Hardware: Pixhawk4 and Cube Orange
Camera: Sony A6000 and Sony A7R
Airframe: Generic Quadrotor and Generic VTOL
Mixer/Actuator: v1.12.3—defined by mixer file and v1.13.1—defined by mixer file and control allocation (SYS_CTRL_ALLOC=1)
TRIG_INTERFACE: Seagull MAP2 (over PWM) and GPIO
TRIG_ACT_TIME: 200ms
TRIG_INTERVAL: 40ms
TRIG_POLARITY: 0: Active low
TRIG_MODE: Distance based, on command (Survey mode)
CAM_CAP_FBACK: Always Disabled
Trigger pin: AUX5&6

1 Like

#!/bin/sh

@name Generic Standard VTOL

@type Standard VTOL

@class VTOL

@board px4_fmu-v2 exclude

@board bitcraze_crazyflie exclude

@board holybro_kakutef7 exclude

. ${R}etc/init.d/rc.vtol_defaults

param set-default CA_AIRFRAME 2
param set-default CA_ROTOR_COUNT 5
param set-default CA_ROTOR0_PX 1
param set-default CA_ROTOR0_PY 1
param set-default CA_ROTOR1_PX -1
param set-default CA_ROTOR1_PY -1
param set-default CA_ROTOR2_PX 1
param set-default CA_ROTOR2_PY -1
param set-default CA_ROTOR2_KM -0.05
param set-default CA_ROTOR3_PX -1
param set-default CA_ROTOR3_PY 1
param set-default CA_ROTOR3_KM -0.05
param set-default CA_ROTOR4_AX 1.0
param set-default CA_ROTOR4_AZ 0.0
param set-default CA_SV_CS_COUNT 4
param set-default CA_SV_CS0_TYPE 1
param set-default CA_SV_CS0_TRQ_R -0.5
param set-default CA_SV_CS1_TYPE 2
param set-default CA_SV_CS1_TRQ_R 0.5
param set-default CA_SV_CS2_TYPE 3
param set-default CA_SV_CS2_TRQ_P 1.0
param set-default CA_SV_CS3_TRQ_Y 1.0
param set-default CA_SV_CS3_TYPE 4
param set-default VT_TYPE 2
param set-default MAV_TYPE 22

→ this px4 github main version

#!/bin/sh

@name Generic Quadplane VTOL

@type Standard VTOL

@class VTOL

@maintainer

@output MAIN1 motor 1

@output MAIN2 motor 2

@output MAIN3 motor 3

@output MAIN4 motor 4

@output AUX1 Aileron 1

@output AUX2 Aileron 2

@output AUX3 Elevator

@output AUX4 Rudder

@output AUX5 Throttle

@board px4_fmu-v2 exclude

@board bitcraze_crazyflie exclude

. ${R}etc/init.d/rc.vtol_defaults

param set-default PWM_AUX_DIS5 950
param set-default PWM_MAIN_RATE 400

param set-default VT_TYPE 2
param set-default VT_MOT_ID 1234
param set-default VT_FW_MOT_OFFID 1234
set MAV_TYPE 22

set MIXER quad_x
set MIXER_AUX vtol_AAERT

set PWM_OUT 1234

→ this px4 1.12.3 stable version

I think set MIXER_AUX probelm

Mixer for an AAERT VTOL

Aileron 1 mixer

M: 1
S: 1 0 7500 7500 0 -10000 10000

Aileron 2 mixer

M: 1
S: 1 0 7500 7500 0 -10000 10000

Elevator mixer

M: 1
S: 1 1 10000 10000 0 -10000 10000

Rudder mixer

M: 1
S: 1 2 -10000 -10000 0 -10000 10000

Throttle mixer

M: 1
S: 1 3 0 20000 -10000 -10000 10000

→ px4 1.12.3 stable version

it is setting AUX 1~5 with pictch, roll, throttle, rudder and it don’t active AUX 6
so it is not working pwm and i don’t change AUX 1~5
I think, it is working only commander

but px4 github master active allocation. so i can use cameratrigger

I can reproduce and confirm that the current master (22-nov-2022) seems to fix this issue. I wonder what the PR relates to this issue, I will try to merge it into v1.13.1. Because the UAV has already passed the flight test in MISSION mode. I don’t want to use the current master to avoid software bugs or unknown cases. @Jaeyoung-Lim @GriTRini