Camera trigger not working on Pixhawk

Please help with camera trigger feature in PX4.
My setup:
Hardware
Iris frame with Pixhawk with PWM driven LED attached to AUX2 pin.
Led is STROBON v2 which turns on on 1700 and off on 1500.
Autopilot config (QGC)
PX4 Firmware: 1.5.5
Trigger mode: Distance based mission controlled
Trigger onterface: Seagull map2 (PWM)
Aux pin assignment: 2
TRIG_ACT_TIME: 1000 ms
TRIG_INTERVAL: 2000ms
Mission
three WPts ~50m apart:
1 Takeoff
2 WP1
3 Camera trigger distance: 10m
4 WP2
5 Camera trigger distance: 10m
6 WP3

Result
Expected to see LED flashing on ~4 times on each segment but no luck.
Verified that LED does work via RC switch when AUX2 is configured to passthrough RC channel in Radio setup.

  1. Could not find any setting how to configure the exact PWM values for camera trigger. Something like: Camera trigger means set PWM on AUX2 to 1900 for 1 second and then back to 1200.

  2. It would be really nice if PX4 supported camera trigger command from GCS so that I could try it without actually flying. There is an “Individual command” mode but I could not find that command in QGC interface.

  3. “Always on” modes did not work for me either.

Thanks.

Reviving because I was trying to remember where these files were, found this question, then I figured it out on my own before I found an answer…

The camera trigger driver is not enabled in the default PX4 build for the first generation Pixhawk (fmu-v2) [due to memory constraints actually caused by a problem from the manufacturer when writing to the second half of memory…] The first step might be to just try upgrading the firmware, since later Pixhawk batches did have a different revision of the chip (fmu-v3) that did work correctly so more drivers are enabled by default.

If that doesn’t work you can download the px4_fmu-v2_multicopter.px4 firmware (or whatever the appropriate one for your target platform is) from the releases page. If you are building form source you can “make px4_fmu-v2_multicopter” instead of “make px4_fmu-v2_default”, for instance, or uncomment the line in Firmware/boards/px4/fmu-v2/default.cmake if you’d rather do that.