-8 deg pitch angle setpoint on takeoff

Hello,
I’m having issues during takeoff where my multirotor pitches up or back on take off, this happens every time, no matter the mode (Stabilize or AltHold)

Things to Note:
I do not have a GPS installed.
I’m running a mRo Pixhawk 2.4.6
The board is mounted SENS_BOARD_ROT: 4 = Yaw 180°

Pitch%20Angle

You can see in the Flight Logs that the Pitch Angle jumps down to -8 degrees on takeoff.
The pilot has to hold 35% forward pitch to get a “normal looking” vertical takeoff.
Eventually you see pitch figure itself out after about 20sec of flight.

https://logs.px4.io/plot_app?log=f3be876a-bcba-4e67-9044-d37d2af6f7ac

Any suggestions on how to prevent the pitch back on takeoff would be great!

@Crazy1Pilot what you observe is the integrator in the pitch controller that takes some time to adapt to an imbalance on your platform.

The fix is either to move the CG, or use a different mixer adapted to your geometry.

First, you have to make sure that you chose the proper mixer. I saw that you use octo coax wide, which is not a symmetric geometry. Please check that your motors are positioned as written in the corresponding geometry file: https://github.com/PX4/Firmware/blob/master/src/lib/mixer/geometries/octa_cox_wide.toml (measured from the CG)

@jlecoeur I have the exact same issue even though mine is with a tricopter frame. Each time I take off, the copter pitches forward. I just raised a topic here Tricopter pitches forward on take-off.

I have looked at the toml file which contains the geometry of the tricopter. It appears, the tail rotor is slightly further away from the CG compared to the other two. However, I am using the tricopter frame from RC explorer which uses a somewhat symmetric equal length of arms from the center. Asides extending the length of the tail arm, how else can I sort this out? can I reduce a scaling or something in the mixer? And if yes, how can I do this? Thanks in advance for your help.

Hi @tecdee can you share a log ?

hi @jlecoeur here are some logs from when I was about to take off.

In the first log, I tried shifting the trims from their center position (for pitch - so I shifted it backwards). That seemed to make it start tilting sideways. So you can see some non-zero setpoint values in the roll/pitch plots.
https://review.px4.io/plot_app?log=c068b871-3d45-4248-8e35-b59c0f8044ce

In the rest of the logs, I re-caliberated the radio, accelerometer, gyro, and level horizons. I also increased the I gains for roll and pitch from 0.05 to 0.15; it still pitches forward. Don’t know if it’s a tuning issue.

https://review.px4.io/plot_app?log=1e4c1c6f-be77-44b9-9981-7ac016667126

https://review.px4.io/plot_app?log=652a6f04-ab36-412e-856c-448bbe8fb62e

https://review.px4.io/plot_app?log=4dd88ce0-5b9a-4dfe-8670-cbaff2faacf5

I’ve actually gotten it in the air before, but the issue is that it is quite difficult to fly because it pitches forward constantly. Moreover, I’m flying indoors and because it needs enough thrust to get it to overcome the pitching and get in the air, it ends up shooting off into the ceiling which I don’t want.

I have already extended the length of the tail arm outwards. Though I’m now thinking of pushing it back in as I just realised that the tail motor is slightly at a higher level compared with the front two due to the servo mechanism it sits on. So in theory it should have a shorter length compared with the other arms yes?? Not sure about this though.

Looking forward to your comments and suggestions. Thank you

It is difficult to help when the drone is not flying.

Two things already:

  • if it pitches forward, extending the rear arm will make things worse
  • On some logs it pitches UP when you increase throttle. Are you sure that the autopilot is correctly oriented, and level when the drone lies on the ground. You can check that with the artificial horizon on QGC.

It would help if you had a log where it flies.

@jlecoeur I have a log where it flies. Older logs though. see below:

https://review.px4.io/plot_app?log=74bf4a8b-f857-4829-a820-a18ee8d54794

https://review.px4.io/plot_app?log=f1987aad-4c5d-48dc-8e67-f610b0e15ec9

About the arm, I will push it back in.

I have now upgraded to version 1.9.2, now it tilts sideways (slides to the left). I decided to use Mavlink Inspector to look at the pwm values going to the motors. When unarmed, they values stay at 900 for all three motors (main 1 to 3). When I arm they all go to about 1550 or so with slight variations 1549, 1548 etc. Then I throttled slightly (attempting to hover), then I noticed that the output is very different between motor2 and the other 2 motors (motors 1 and 3). It still leans/slides to the left (viewed from behind).
See image attached. And the log with v.1.9.2 is given next.

https://review.px4.io/plot_app?log=460257bc-c6db-4e76-af8c-280ba2224d4e

So right now, we’re sliding/leaning to the left hand side (viewed from behind the copter), and no longer pitching forward.

Thank you for responding and helping out with this.

On the second log, you can see that the drone believes it has a few degrees of pitch up attitude, which it tries to correct as soon as you take off by pitching down.
Calibrate the horizon and it will be better.

@jlecoeur Yes I can see that. on updating the firmware to 1.9.2, I re-caliberated everything from compass down to level horizon. Its just strange from pitching, now its rolling (sideways).

I’ve observed something else. In ver 1.8.2, when i power the board, the tail rotor is tilted to the left (viewed from behind), then when I turn off the safety switch, it goes to the center, then I arm.

Now with v1.9, when I power the board, it is tilted to the left (viewed from behind), when I turn off the safety switch it goes to the right (not center).

I will re-caliberate as you have advised. Now I don’t know whether to put back 1.8.2 or leave it at 1.9.2, thinking about that now.

@Crazy1Pilot were you able to sort out your issue?