Tricopter pitches forward on take-off

Hi everyone,

So I have a tricopter using pixhawk1. A summary of the specs is given below:
-Emax RS2205 motors, with 5045 HQ props.
-BMS210DMH servo
-Px4Flow camera with LidarLitev3 rangefinder
-Aikon32 ESCs
-3S 1800mAh Turnigy LiPo Batt.

I have two main issues:

  1. Whenever I take-off, the tricopter pitches forward. I’ve tried to balance the CG using the battery, and even by adding some weight to the tail landing gear, still no luck. I am beginning to think the tail arm is far too forward and so the CG is much further forward than it should be.

  2. When I takeoff, the the copter shoots into the sky. it was actually worse when I was using a 4S battery and 6045props. With the previous specs, the copter was very powerful, and I set the MPC_THR_HOVER parameter to 25%. So the lower half of the stick was only 25% of the overall thrust, leaving the upper half with a whooping 75% such that as soon as I push the stick slightly above the middle, it just shoots up into the sky. After dropping to a 3S and to 5045 props, it is a bit better but it still goes much higher than I want (I am flying indoors without GPS).

I am also now thinking the forward pitching on take-off may be contributing. The reason I say so is that when about to take-off, I can see that the tricopter is already leaning/sliding forward (meaning it would have already been in the air) and so it needs much more thrust than required for hovering before it can actually leave the ground. And then after I have increased the throttle stick further to when it eventually gets in the air, the thrust is actually too much for it. Just a theory anyway.

Any help or suggestion whatsoever will be greatly appreciated. And sorry for the long post.

Thank you.

New be Looking for help with trycop build Using Pixhawk 2.4.8 from amazon and I can’t get the tail servo to do anything. What’s wrong Wiring, firmware, or me. Any help from anyone please. Thanks

@Ticoe provide some more information and I may be able to help. What configuration are you using? Y+ or Y-. For some reason, I find that the Y+ had issues for me. Only Y- worked for me.

Not sure. Y never saw it described as. + or - Two arms in front, servo at the tail of the. Y

Be patient old man here. Lol

Just got half my problem solved. In full parameter list find servo7_function and change the value to 41 not 39 like Manuel said, Walla it works

Alright glad its sorted. Mine’s still pending. hope someone reads and replies

I’ve had problems with other copters tilting to the Left or right. Without input on my part . I found In my case a little oil In the motors and they ran even and better. Maybe