Quadplane keeps pitching forward at takeoff

Hi All

I am fairly new to using Pixhawk (using Holybro PX4).
I have recently done a VTOL conversion on my ranger.

Every time I test in multi-copter mode the plane keeps pitching forward.
Anyone with guidance on what is causing this?

Here is a link to the log file log file

I’ll leave the log analysis for someone else. A video would help but I have the following questions:

  • Did you do a Level Horizon calibration?
  • Did you check to level the MC booms before Level Horizon calibration in QGC?
  • I changed the tailwheel wire with a longer one to keep it mostly level when it’s on the ground.
  • If you’re interested, here’s a playlist of my build.

Good luck.

Hi rollys

Thanks for the reply. Your build looks amazing, well done.
My setup is very similar.

I have done all the calibration in QGC and have a green board.
For some reason I am not getting any stability control from the autopilot.

Any chance you can fwd me your parameters so that I can check against mine?


This was my last one in 2017. Just delete the “.pdf” at the end of the file then unzip it. Use Excel to open the params file to use for comparison. DO NOT import it directly into your FC.

Good luck.

QuadRanger Pixhawk v1_7_1 012618.zip.pdf (6.2 KB)

thanks a mill. will go through this and hopefully find something that I am missing :slight_smile:

Hi @crashalot ,

from the log, the autopilot really tries to correct the pitch down motion by setting the front motors (0 and 2) to full throttle. Are you sure that your wiring is correct?

Good luck

Hi Bresh

Thanks for the confirmation on the log file that the autopilot is trying to correct the pitch.

I am going to re-check the wiring sequence and confirm.

Hi Everyone

Thanks again for the useful suggestions.

I have now found the problem: Front right and Back right motors where swapped…doooh.

After correcting this, she hovers beautifully :slight_smile: