V1.4.1 Release testing

Hi All,

We have only a few issues left to resolve for 1.4.1. While the core team will do the flight testing for these fixes, we would benefit from some general flight testing on these aspects:

  • Multirotor altitude hold / position hold vs. 1.3 stable using the default estimators
  • Multirotor altitude hold / position hold when enabling LPE (see the System parameter group for the estimator selector)
  • Fixed wing general performance and auto takeoff

It would be fantastic if you could put in a couple of test flights this weekend so we can get 1.4.1 finally out of the door.

1 Like

@dagar @Mark_Whitehorn @PKocmoud @jgoppert

http://logs.uaventure.com/view/ZWrto8kKKyszWzNswzQuyN
1.4.1rc3 EKF2 hexacopter

Flight is stable but I don’t understand:

  1. why GPSP.alt sometimes not correlate with GPS and baro sensors
  2. LPSP.Z at 14:33 is under the ground

http://logs.uaventure.com/view/YMZnYaFAvK5icjSNzwHT5A
another flight with EKF2

LPSP.x and LPSP.y in ALTCTL mode are too high

high altitude (150m)
http://logs.uaventure.com/view/8kBhiED5fLrqaDpoZLNRmN

high speed (85km/h)
http://logs.uaventure.com/view/UVcMoNyFHEfu43vKWz6uCH

another question - why in mission mode altitude setpoint is like quadratic function when vertical speed is linear?

it seems that distance sensor fusion in EKF2 is broken

Hi all :slight_smile:

after a couple of month thinking about other stuff than copter and pixracer, I finished my test copter build with the pixracer. Now I flashed the 1.4.1 firmware and I made some test flight in my garden in stablized, althold and pause (loiter).

Stabilized works perfectly like a charm! very nice! AltHold, I’m not sure if it dose it right. the copter seams to be a bit nervous but it keeps the altitude, so I prsume it is working fine. Where can I change the agresivity of the recation in AltHold?

I tried the (Loiter) Pause mode but this is extremly nervous and not very nice to engadge/fly. Where can I set this mode les agresive? To me loiter has to be smooth and gentle not as agressive as it is now. And due to not being able to give stick inputs (ticket is open) it make me feel like having zero control of my copter :frowning:

Here are the logs mybe someone can have a look at it
http://logs.uaventure.com/view/T82HpEE4irBvrVWbFgH4VC

Thanks

@Sn0west Thanks for the feedback! I would really recommend to use position control instead of HOLD (which is the new name for loiter if you use a recent version of QGC). I don’t think you really want to use hold in your use, so just don’t fly in it. We’ll look into recommendations to tune down your position control gains.

@Sn0west Your rate gains are pretty high, I recommend to tune MC_ROLL_RATE and PITCH_RATE P a bit down. Your system is overshooting, which makes it overall “twitchy”.

Thanks for the reply Lorenz.
I did some more tests and I used position control now. It’s not exactly what I would like to have. I used to use a lot “Loiter” in arducopter language, because it is very convenient to “park” my copter or to do a shot from a specific point. But anyway, if I use position control and do not give any stick inputs it should act the same as “loiter” or to say it in px4 language “HOLD”, right?

Look at my video, it move a lot in the aire, there is almost no wind at all, so I don’t understand this nervous behaviour and yes the slider in the tuning tab is all to the right.

My logs are here
http://logs.uaventure.com/view/MmeB27SkxLWKMy3XKPUNE6

Thanks

@Sn0west thanks! Looking at the log I think you could try dropping these two gains:

  • MPC_ACC_HOR_MAX = 5.0
  • MPC_XY_P = 1.0
  • MPC_XY_VEL_P = 0.9

You can try to drop the last two further if the oscillations still persist.

Two things I saw looking at the plot:

  1. The velocity control seems to overshoot the velocity setpoint. You could try to lower MPC_VEL_P or raise MPC_VEL_D.

  1. The accelerations measured are quite high, not sure if this has an influence. Is the Pixhawk mounted on some foam?

1 Like

It still act like a crazy horse in the air. It seams like it would be searching the perfect spot to stay but constantly overshooting.

I need some more information about the exact definition of Position control, so I will open a new tread because here is the wrong place to talk about the PosContorl settings.

@svpcom Thanks for the fix for EKF2! Can you arrange cross-testing of your lidar sensor driver change with other developers?

@jgoppert, @ecmnet Could you test new SF1xx driver with SF10a lidar?

We have really bad weather conditions to flight at the moment. Will test it as soon as possible.

Hi everyone,
I’ve tested 1.4.1 rc3 with my tachymeter tracking setup. In general I’ve been able to tune MPC PID parameters to achieve stable position control with LPE.

There are however a few things that I don’t understand.

  1. The spikes in setpoint velocity look weird, will the further PID tuning help eliminate those?
  2. At T=100 the estimator seems to break?

http://logs.uaventure.com/view/u42kUDFPpdKjyFwtUaq5ET

Appreciate any feedback.

I need to look at the plot in detail. The estimator resets its internal position to zero at arming, which is what you’re likely seeing. I need to inspect that behaviour again. I just merged a couple of further improvements to beta.

@Sn0west Will look into your log again and suggest changes. The other issues reported here should be fixed on beta.

I did 4 flights with today’s morning master GIT_TAG = v1.4.1rc4-39-g00d4eae :
Small copter 450 class, moderate wind around 3 m/s with gusts around 6 m/s.

LPE performance was much better than previously, without twitching in XY plane. Altitude deviation around 1 - 1,5 meters:
http://logs.uaventure.com/view/P76QbzQR5CP6m9B7nPiKk8
http://logs.uaventure.com/view/mtD3ieEYqUmVonFJt4YLXF

INAV shows less twitchy flight but awful altitude hold with 2-2,5 meters jumps:
http://logs.uaventure.com/view/qH7tTo2aYdkTfY3M5ckw5A

EKF performance was similar to LPE, I didn’t noticed significant differences, maybe altitude hold was a bit more stable:
http://logs.uaventure.com/view/JDcmWcqrJCoSNJDKdcY7Hh