VTOL FW Flight Mode problems

Hi all,
I’ve converted a GoDiscover Delta wing into a VTOL using a Pixhawk 2.1 with GNSS, along with a FrSky Taranis X9D Plus Mode-2 Transmitter and L9R receiver. Programming through QGround Control. I’m using the DeltaQuad wiring profile shown below. Here is the reference link: https://docs.px4.io/en/airframes/airframe_reference.html#vtol

DeltaQuad :
Specific Outputs:
• MAIN1: motor 1
• MAIN2: motor 2
• MAIN3: motor 3
• MAIN4: motor 4
• MAIN5: Right elevon
• MAIN6: Left elevon
• MAIN7: Pusher motor

Quad mode seems to work as expected. I have the basic fixed wing mode working by using the right side slide switch, channel 8, for transition from quad to VTOL and back again. So far so good…on the bench…

Problem I’m having is the Flight Mode settings.
Any Flight Modes set, other than Stability and of course, VTOL, adversely effect Fixed Wing mode. Basically it locks up and I have to switch back to quad to regain RC control.

So no luck setting up Mission mode or RTH. Would also like to set up a Geofence. My goal is to fly autonomous missions. Again, this bird is on the bench, so I haven’t bothered with logs yet. (should I or wait til I fly?)
Hoping to work this through and fly in the next day or so.

Any and all sage advice is greatly appreciated!
Thank you.

I highly recommend you change your airframe to Generic quad delta VTOL SYS_AUTOSTART = 13006 and wire accordingly. Bench test to make sure servo directions are correct by pressing the safety switch, then switch to FW mode. When left wing is down, you should see left aileron down/right aileron up and vice versa; pitch down and elevons go up and vice-versa.

Use an airspeed sensor and make sure FW_ARSP_MODE is Enabled.

With the default settings, she should fly fine but you may find you’ll need to adjust the PIDs to make it more reactive, depending on your power and prop setup. My RVJet VTOL is about the same size as your GoDiscover and it didn’t take much to get it flying well.

Hope this helps. Good luck.

1 Like

Big thanks for that fine advice! Will do.

I do have an issue with the airspeed sensor in that the 12c wire provided by the Pitot sensor kit does not fit the Pixhawk 2.1 Cube 12c port. It seems it was made for the previous build of pixhawk ports, so I will have to make a custom wire.

I see that I can disable Wind Speed sensor through the FW_ARSP_MODE input. Probably not wise but doing so will move me forward until I have that custom wire ready.

BTW I am considering getting the RV Jet next. Seems like a fine ship!

Unless you know the specifics of your aircraft’s performance, i.e. throttle position that will insure it doesn’t stall on any flight regime or how long it’ll take during the MC to FW transition to make sure it’s flying at cruise speed before the quad motors stop, the airspeed sensor is pretty much mandatory. I’m a newbie myself on VTOLs but have converted and built several of them to have a basic understanding so they can fly right. At least to a point that I don’t have to be constantly on my toes flying them.

If you still have to purchase an airspeed sensor, you may want to check with mRobotics or Drotek to see if they can provide provide the harness with the correct plugs to fit your 2.1.

Also, if you haven’t yet, register at PX4.slack.com for the PX4 forum. The dev team actively monitor and respond to posts for assistance should you find the need.

Good luck.

1 Like

Ok this vtol is now set to Generic and yes the flight modes are now behaving properly. Everything but the ailerons look good.

On the bench today, my servos seemed a bit off. I got better results after adjusting the trim switches on my radio but still not quite right. Maybe its a bench test behavior, not sure. On QGC, what’s the command for the aileron trim and invert settings for this Generic VTOL setup?

Thanks Rollys!

It’s never a good idea to use Tx trim. Keep in mind, it will affect both flight modes, i.e. if you put right trim in FW, when you switch to MC, the aircraft will drift to the right in Stabilize and fight itself in Position or Loiter which could unnecessarily draw more amps or make the motors increase in temperature. The best way is to zero out all your trims, then use bubble levels on both lateral and longitudinal axes of your quad booms and calibrate Level Horizon of the flight control from that. This way, in hover mode, the FC will maintain level with respect to the motors. While at this position after calibration, adjust all your control surface linkages so all are neutral before powering down.

This is how I do mine and is best done with an observer. Setup a Manual mode in your Tx flight modes so can go from Stabilize or Altitude to Manual easily and vice-versa.

  • During flight tests in FW, switch to Manual and use the trim to maintain level flight.
  • Have the observer take note of the trim settings, i.e. how many clicks it took.
  • Zero them back and land.
  • When on the bench turn on aircraft and Tx, switch to FW Mode - Manual and set your trims to the observed settings during flight.
  • Mark/measure the control surface deflection of each control surface.
  • Zero out your trims
  • Adjust the clevises to match the marked/measured deflection.
  • Test fly, adjust and repeat above steps as needed.

Good luck.