Tailsitter Duorotor Feedback

This thread is for feedback on the duo rotor tailsitter.

1 Like

I am building a tail sitter that lacks a rudder. While in airplane flight, can the motors provide differential thrust to compensate for YAW?

Have you seen this page? https://pixhawk.org/platforms/vtol/tbs_caipirinha_vtol

Yes, but I do not see an answer to my question there or anywhere so far.

I have modified this plane: http://www.horizonhobby.com/delta-ray-bnf-with-safe-reg%3B-technology-hbz7980 with a PixRacer, brushless 2300KV Motors with 6x4.5 props and OneShot ESCs to be a tail sitter platform. It hovers at < 50% so far.

1 Like

For a Caipirinha, in which orientation do I calibrate the Level Horizon Sensor? Nose up?

Thank you,


Aha I have found the right place to ask stuff!!! Just cutting some foam to mount a Pixhawk and try this tailsitter concept. I asked on the Google group, is an airspeed sensor absolutely required?

@thedudevt Nose up for level, yes. You should get a close to level attitude already after configuration and after levelling it should be perfect.

@Gary_Mortimer The airspeed sensor is used to infer when its safe to transition. You can hack around it, but its fundamentally required if you don’t want to stall (e.g. in slight tail wind).


here http://dev.px4.io/airframes-vtol-caipiroshka.html in the last table is written that motors run with 50Hz and servos with 400Hz. Is this a mistake and the other way around is correct? Furthermore: which init.d corresponds to Caipiroshka?

BTW: at my tricopter I use a 400Hz servo and I “feel” the difference in precision compared to 50Hz servos. Maybe this also applies to Caipiroshka.

Best regards,

I think it’s a mistake and I will fix it!

Verry interresting, can you tell more about?
Experience, speed.
Perhaps a picture of the inside?

In MC mode (nose up), I get yaw correction (opposite flaperon movement) when I rotate the wing about the vertical axis but I do not get any flaperon movement when moving the yaw (rudder) stick. This is not surprising as the main.mix flaperon mixes are mixing S:1 0 (roll) and S:1 1 (pitch).

When I set the flaperon mixers to S:1 1 (pitch) and S:1 2 (yaw) I lose yaw correction and I still do not get flaperon movement from yaw stick input.

Is there a parameter I am not setting correctly?

In the current configuration, how do you yaw the craft in MC mode?

Thank you for your time,


Leave the mixer as is, I think it’s ok. Could it be that you are testing this on the bench. Because probably yaw control is only working when you are in air. Are you experiencing these problems in air?

Hello all,

I have another issue - manual “pitch” and “roll” commands stay “locked” to the orientation of the plane at the moment of powering up / arming. That means, if you have made a 90° yaw-turn in the air, and than give manual “pitch”, it will be actually “roll” acc. the plane, but it will tilt the plane in the same direction as “pitch” would do at start position. It is like some “simple” flight mode for multicopters (like http://ardupilot.org/copter/_images/SimpleModeControls.jpg from the Ardupilot project).

Do you have the same behavior and do you know where in the PX4 Fligh Stack or QGC this can be deactivated/activated?


Hi Ivan,

I think the problem you are encountering is this one https://github.com/PX4/Firmware/issues/3620
It should be fixed within the next few days.

BTW, I’ve tested the Caipi with latest master and it flew well indoors.

Hi Roman,

thank you for putting this on the todo list!
My flying wing is also doing well in- and also out-door, just have to keep the yaw angle constant to be able to steer it :slight_smile:
If you need to test somethiung, please let me know!


Hi Ivan,

good to hear that! Can you share a photo of your wing?


here it is, hoovering at my workshop - Swift, 800mm wing span, € 40,- (makes 5 cent per mm of wing span :slight_smile: ). the elevons have 30% of the chord lenght and it works well that way.

and a close up here