Pixhawk 4 device driver not found!

I connected my Pixhawk 4 to my Windows 7 PC via the provided USB. It’s not being detected by the QGC.

I looked in windows device manager and this is what I see:

I thought QGC already downloaded the necessary drivers when I installed it. Does anyone know where I can get the right device driver for this?


The lights on the GPS are slowly blinking and the blue (ACT) light on the Pixhawk 4 is also blinking while the green lights are solid.

In the directory where you installed QGC, do you find any .inf files that could be drivers?


I don’t think I see any .inf files in that directory. I even tried doing a search there for “.inf”. It returned nothing.

I am struggling to find even an external source to download the required drivers from. The strange thing is, despite some initial errors and all, Mission Planner managed to communicate with my Pixhawk 4.

That’s odd. Does Mission Planner still manage? And do you know what driver files Mission Planner brings?

Yes. Mission planner seems to work. Although, I don’t fully trust it yet.

I tried to install and run Mission Planner (MP) and this is what happened:

  • It installed everything including drivers and asked me if I want to use the setup wizard. I said yes.

  • It asked me to plug in my Pixhawk 4 but then this happened:

  • It said that the connection failed, so I was sad but then I noticed this happening:

  • I had no idea what that was that it managed to make work. So I clicked on that “Details” of the connection failed error and got this:

  • As the wizard seemed to start working even after those initial errors. I started noticing these problems where no matter what I did, it wouldn’t let me see the full texts,

  • I went ahead anyway but ran into similar troubles along with a strange one where the wizard wouldn’t accept me typing in any damn number at all! Firstly, as you will see in the pictures, it’s difficult to see what I am typing in because of that grey thing over the field. On top of that, I’ve typed in 2200 mAh (without the mAh part) in many different ways just to make it work. It simply will not accept ANY input.

After all of that, surprisingly, it was kinda sorta working. I could see the sensor readings and my approximate location on the map.
I’m confused as to what’s going on. What’s the thing that happened with the driver and COM port? Why does the wizard GUI not show me all the texts or even let me enter ANY value for the battery?

UPDATE: QGC notified me of an update release (v3.5) so I downloaded that and installed it. Now it looks like it finally recognised my Pixhawk :smiley:

1 Like