PixRacer Has No FRSKY or SERIAL Parameter Listed in QGC

#1

I have two Pixracers both flashed with the latest FMUv4 rom data. I’m using the latest QGC. The Parameter list does not include FRSKY or SERIAL (not seen in Mission Planner either - must be firmware!?)
I want to use the FrSky port to push telemetry back to a Taranis X9D. I used https://docs.px4.io/en/flight_controller/pixracer.html for “how to” on wiring up, though correct wiring seems irrelevant if the controller does not even know the port exists!

A ton of frustrating on-line hours spent on this. Anyone else seen this problem or have a clue?

1 Like
#2

I don’t use Pixracer but on my Pixhawk, I had to use the Developer version for it to work. I believe it’s only available there until the next stable release.

Good luck.

#3

I appreciate knowing I’m not alone in experienciing this problem.
I encountered a comment previously about the “developer” version previously, and assumed it was the GitHub current master, as it means nothing to Google? I forked and cloned god know how many hundreds of megabytes, tried to locate the magic file, ended up semi guessing, and tried to Make it.
It started, and then claimed something was missing. I said f— and went for a coffee, muttering I just needed patience and the “latest firmware” would catch up sometime.
It may look like I’m lazy, just asking for a copy of the magic firmware, but I’ve wasted a ton of hours on this, and my head now goes into a spin when I think of a GitHub path to success.
Thanks for replying.

1 Like
#4

Hi @KJBB

On the Pixracer, the FrSky Telemetry Driver runs automatically on the FrSky Port, you don’t need to configure it. This is true for both the PX4 stable release and master.
On the console you can check with frsky_telemetry status if it’s detected.
Does that help?

#5

Would be nice if it were present in the parameter list. Then I would have the luxury of not needing to configure it.
In shear desperation, I have ordered a third Pixracer from an in-country source - maybe a week from now- so that I can have at least one operating, or complain to a local source if not!
I did some research to see if I could “copy and paste” the firmware from the third one, but so far I have not seen how - must be possible.
Thanks for your interest. I’ll post results when it arrives.

#6

I am pretty sure that these parameters (which are in the online documentation) are not available in 1.8.0 or 1.8.1 Firmware. I believe they were a post-1.8 change. Perhaps they will be included in 1.9. So I doubt you will see them even if you purchase another flight controller.

#7

Well, the advert promises an FrSky port. So, if not, I can send it back or complain, and try to get the supplier to sort it out. Will post a result.

#8

I have learned that you can install the current development master version of the firmware to get these parameters. Inside QGC, firmware, advanced.

#9

Well, it’s good to know that it is intended to be in new releases. By current master, I take it to be from GitHub. I already cloned hundreds of megabytes from GitHub, and got lost in a morass of files. I think I will be patient, await the new FC, and probably await new firmware release.

Let me say however I am much heartened by your advice. Many thanks for your efforts. There may be others who will dip into these posts, see the good news, have more courage than me, and follow through!

#10

You can download and install (onto your pixhawk) the development master without github, cloning, building, etc. from within QGroundControl. Go to the Firmware tab then Advanced. It’s called “dev(master)” or master(dev) or some such (not at my computer at the moment).

I agree about posting resolutions to questions on the forums here, I have learned a lot by reading others’ problems and resolutions. Perhaps someone will learn from this one.

#11

Done. FrSky port appears. Had heard of an Advanced tab in QGC previously for firmware, but did not know how to access it.
I was looking for how to send a private message on this forum. Not found. I wanted to encourage you to keep talking to an amateur, an amateur who has a degree in electronics (1968), and has done a lot of programming in the distant past (Windows development) but who was very unsure about read accross to GitHub. C++ for example on the Windows development environment seemed to offer a simple Project overview with minimal setup to include vast libraries A/R. The details of the build were hidden. Seemed to me that with GitHub one had to manually include dozens of modules? Or perhaps my ignorance obscures the simplicity?

Will still post when I get the new Pixracer.

Thanks for your patience.

#12

Waiting for new Pixracer… post when arrives.
Just a little note here meantime, showing how human speak and computer speak are not good bedfellows:
Christopher’s advice above “Go to the Firmware Tab, then Advanced” tripped me up as I read it as “…then Advanced TAB”, and of course Avanced is not another tab, but a check box, and I then got stuck! More grumblings about gremlins ensued.

#13

New Pixracer arrived. Although advertised as having an FRSKY port, it did not. Have complained to the supplier. Perhaps his supplier will explain why not?
I learned how to get the “master” firmware installed, and this produced the missing port. I understand “master” to mean the latest version, which may be under development- the next pending release.

Displaying flight info on Radio?
#14

I guess the FrSky driver doesn’t load automatically in v1.8.1 master. This is what I had to do on my Pixhawk. Hopefully most of it will work on your Pixracer.

  • Download the v1.8.0 master file below and save it on your PC.
  • Once saved, remove the “.stl” at the end of it. The only extension should be .px4
  • In QGC, click on Firmware tab, plug USB then choose Advance then on the drop-down menu, choose Custom File, then click OK.
  • In the ensuing window, point it to where you saved the file.
  • When it completes and you go to the Summary tab, it should show 1.8.0dev
  • Not sure if with the Pixracer you have to do this but check to see if it’s working from the FrSky port.
  • If not, click the Parameters tab and type SYS_COMPANION then choose FrSky Telemetry.

Good luck.

px4fmu-v3_default_master.px4.stl (1.3 MB)

Make px4fmu-v2_default
#15

That worked out fine. Thanks for your assistance
I may however be opening a new topic (or joining an existing one) about a missing PX4FMU driver. It was fine until a short time ago, but after installing some software it vanished. Re-installing QGC or Mission Planner, etc, does not restore it. If I dig down in the QGC directory I find an .msi file but if I run it I get "could not be opened…contact vendor) that on both desktop or laptop. Had this problem 6 months ago. Aaaaarh! Bloody computers.

#16

I’m glad you got it working.

You can maybe try an older version.

If that doesn’t work, you can try doing a System Restore. It may have been overwritten from a Windows Update or Defender, if you use a PC.

Good luck.

#17

System Restore: Only one found, and that was dated in hours. I must have neglected to set up a restore scheme.Tried it anyway, but no success.
There is a px4driver.msi in QGC’s directory. Running that ends with a Code 10 - cannot start. This must surely be the correct driver? Same on my laptop (Win7) or Desktop (Win7).
If I run (DOS Window) DRIVERQUERY no likely driver shows.
I configured the system to “load all drivers” and accept unsigned drivers -no help. Via Device Manager (add legacy hardware) I got a driver to load but it came with a yellow! Cannot start. Trying to Update Driver returned “you have the latest” - big help.Tried going into Safe Mode in a way that allows installing, I ran the px4driver.msi. Still no driver in Device Manager.
I have a folder with px4flow.inf, px4fmudriver.inf and px4fmu.inf. (lost track of where from) All three result in a FLOW driver with a yellow !, (Why FLOW?) I’m running out of options. Why in both the laptop and desktop!! Thinking of installing a secods OS - a second Win7 perhaps, or Vista, or WIN8 (arghh). Frustrated!

#18

Put a check mark on the box “Show more restore points.”

Have you tried using a different USB cable? This has driven me bananas a few times. Sometimes, I just get “Unrecognized USB device” error.

Also try, while the Pix is plugged to the USB, reboot the PC and see if it recognizes it and starts properly then.

Good luck.

#19

Yes, I have seen a problem in the past with a USB cable. I’m sure it’s the same one I had just used to log into my Taranis transmitter (well, nearly sure)?

It fixed it., but not before I restored to 11/11, then a week further back than that. Whatever I need to do in re-instaling because of the back restore will be as nothing in comparison, and will be done in a much happier mood.

God bless you.

#20

That worked for me, but I notice that you give SYS_COMPANION as the parameter, but the documentation has TEL_FRSKY_CONFIG