Unable to view rtsp video after update to QGC 4.0.6

Hello all, hope your staying safe and healthy.
I’ve got a problem with the new streaming video in the latest QGC 4.0.6 Android.
I had RTSP Video working fine w version 3.x of QGC Android version using the target of “RTSP://”. After an auto update of QGC to 4.0.6 all my previous settings were deleted so I rebuilt everything again. After restarting QGC I got a video window that said “Video Disabled” that I’ve never seen before. Couldn’t find anything in the setup screens or video window to “Enable Video”. After searching around couple hours I found mention of several new video streams and some new option screens under the Telemetry window menus (why there and not the video window itself?). I followed the Video setup doc’s (that needs some serious spell and Grammer checking) and reentered the RTSP Stream info but all I get now is a black video window saying “Waiting on Video”.
Not sure why waiting on video as I can stream video fine to my drone control app and via the WEB interface for my drones ok. I tried restarting QGC, several of the drones and my control app but still “Waiting on Video”. Also tried a couple of the new video streams but nothing works. No video in the window, just “Waiting on Video” msg. I tried to view the “more Video info” from the DOC’s but just get a 404 error that file doesn’t exist from GitHub.
Is there more to setup that I’m missing?

I think I found the problem. When entering the RTSP target, it no longer accepts Capital letters. The old version of QGC (3.5.x) I had entered “RTSP://” and it was working fine.
After this update (4.0.6) that entry resulted in “Waiting for Video”. I accidently reentered but with “rtsp://” and now it’s working.
I didn’t see any mention of this change in Doc’s, is this a bug?