QGroundControl Video Stream not showing in Ubuntu 20.04


I am hoping someone could help me out or maybe confirm that I am doing everything right regarding video streaming from offboard computer to QGroundControl.

I am using gstreamer, and running a command in terminal, but for some reason when using Ubuntu 18.04 and QGC 4.0.8 everything worked fine (my partner also confirmed that QGC 4.0.8 also displayed video stream on Windows 10 Enterprise), but as soon as I started to use QGC 4.1.0 and above no stream was displayed even though the streaming command did no change. To make matters worse, once I upgraded to Ubuntu 20.04 I have not found any version of QGC that would display my video stream.

For video stream I have used :

gst-launch-1.0 -v videotestsrc ! avenc_mpeg4 ! mpegtsmux ! udpsink host= port=5600
can be received by:
gst-launch-1.0 udpsrc address= port=5600 ! tsdemux ! avdec_mpeg4 ! autovideosink


gst-launch-1.0 videotestsrc ! video/x-raw ! videoconvert ! x264enc ! rtph264pay ! udpsink host= port=5600
can be received by:
gst-launch-1.0 udpsrc address= port=5600 ! application/x-rtp, encoding-name=H264, payload=96 ! queue ! rtph264depay ! avdec_h264 ! autovideosink

QGC Video Source is set to: MPEG-TS (h.264) Video Stream, and I also tried UDP h.264 Video Stream

Hopefully someone can point out if I am doing something wrong. If some more information is required, do not hesitate to comment.

Some updates:
Running QGC v4.2.1 on Ubuntu 20.04 with video settings Source UDP h.264 Video Stream .

When I execute following command from terminal on the same machine (or different machine connected via LAN):
gst-launch-1.0 videotestsrc pattern=ball -v ! x264enc ! rtph264pay ! udpsink host=<My IP> port=5600

I get the test pattern in QGC. Then one the fallowing occurs:

  • QGC crashes
  • Machine QGC is running on freezes and becomes unresponsive. (Only a reboot works then)

I see no pattern in the outcome of receiving video in QGC. What I noticed is that my /var/log/ folder has no space left after the freeze.

Hopefully someone can see what am I doing wrong, or if this is a bug of some sort.