Unable to use Mission Mode for Rover Traxxas Stampede VXL

Hi everyone,

I’m looking for advises over the Mission Mode for Traxxas Stampede VXL.
I tried to follow the manual ( https://docs.px4.io/v1.9.0/en/frames_rover/traxxas_stampede.html ) but it says that I should arm the rover in mission mode. it is actually impossible, as pixhawk requires manual mode to arm. I somehow managed to arm it, but it resulted in a crash (unable to retake control).

Does anyone have an explanation for these lines in the user guide :

To use the mission mode, first upload a new mission to the vehicle with QGC. Then, BEFORE ARMING, select MISSION and then arm.

Thanks for your help !

Greg

Does anyone have a clue?

If you have any idea on the proper way to arm the rover, please share!

To use the mission mode, first upload a new mission to the vehicle with QGC.

You need to create and upload a mission first.
See: https://docs.qgroundcontrol.com/en/PlanView/PlanView.html

Then, BEFORE ARMING, select MISSION and then arm.

Then select the “Mission” flightmode by clicking the text in the FlyToolbar, followed by toggling the vehicle state from “Disarmed” to “Armed” right next to the flightmode.
See: (https://docs.qgroundcontrol.com/en/FlyView/FlyView.html)

Your rover should arm and run the mission now(You might need to confirm the mission start via the slider)

1 Like

I’m not allowed to change to Mission mode (error sound and red led)
Maybe it is mandatory to use telemetry? If so, how should I do? (I own a holybro telemetry radio V3)

Thank you so much for your help!

Most likely there are some Preflight-Checks failing. Setting up the telemetry radio would help you identifying the cause of the error live in QGC. See: https://docs.px4.io/v1.9.0/en/telemetry/sik_radio.html

In general I would advice you to check out and browse the User Guide. You will find all kinds of useful information there.