Rover doesn't move in mission mode PX4

Hello everyone!

I have built a rover with a Pixhawk 6c Mini. Flashed it with PX4 Autopilot, configured all sensors, the radio and the servos. Have tried the Manual Mode via RC and the rover drives perfectly.

Now the issue:
I have created a Mission in QGC and uploaded it to the controller via USB. Then I unglugged the USB-cable and switched on the Mission Mode via RC but the rover doesn’t start moving…

I am grateful for any help!

Some additional information:

  • Hardware: NXP-Buggy3-Kit with Pixhawk 6c Mini
  • Firmware: PX4 1.13.3
  • Airframe: Rover
  • Vehicle: Generic Ground Vehicle
  • The Mission has a starting point, some waypoints and RTL.
  • Initial Waypoint Altitude is 0.0
  • Pictures of the rover and some screenshots are added on

Hi, you may consider using a telemetry to upload the waypoint mission, and the QGC will also give you reminders for command rejections in this way

Unfortunately, I don’t have a telemetry module. I tried it with a MAVLINK Wifi-Module but couldn’t upload the mission because the loss rate was too high.

Any other suggestions?

there are a few problems here, so the first is going to be connectivity. unless you modify some parameters (which i do not recommend) you will not be able to launch the vehicle without connecting to a ground station.

So, i would recommend getting a cheap pair of telemetry radios: SiK Telemetry Radio V3 – Holybro Store