I want to upgrade the rover to the tractor

Hello everyone! I use px4 for tractor. (see video). I developed a driver for steering wheel. But i have a lot of problem. First of all, want to start mission from QGC. But… px4 have this code


It’s very safe. From the other hand, I do not fly and I will not crash. How can I disable it? Just leave switch to AUTO_MISSION and ARM? It my first question. Now I go to test my pixhawk, which located in the frost. And I’ll bring you some ekf errors in next post.

Well, second problem. Can I solve it without code? I tried changing settings of commander.


When I can get reason of this situation? Logs are written after arm, but I can’t arm!

Normal temperature (video)
Also this error show with 20 satellite when temperature drops below freezing (0 degrees).


(I use pixhawk 2.4.8). On friday i try to change it on pixhawk original but sensors don’t differ.

Have you calibrate your accels and gyros? Pixhawk 2.4.8 is an low-quality copy of official v2.4.6 with many “enhancements” to reduce its cost. See for details: http://diydrones.com/forum/topics/solution-proposal-for-pixhawk-imu2-related-bad-accell-health

Yes!

I go to test this on the original pixhawk.

To all:
Again, same question. How to always enable mission? Start from command Without arming in Manual?

OK, I checked two pixhawk. Today it work well. But it is an exception. How can I log this events in future?

Publish your logs from SD-card to https://logs.px4.io/ and post link here

First example. (with start mission)
[random example] (https://logs.px4.io/plot_app?log=d72ea072-703a-46cc-9264-c7d81fa02b9f)
(I don’t know how this logs help you, because it created when sensors were warm. In bad situation logs aren’t created)

Vibration is very high. You need to damp it.

Your voltage is 13V, but you set 7 Cell bat in params. It’ll prevent vehicle arming

In my view, you are wrong, because this error show very rarely, if I connect to pixhawk on usb (When it work from vehicle power)

It always work fine (example on video in first post) when the temperature is greater than zero ±.

Have you tried https://docs.px4.io/en/advanced_config/sensor_thermal_calibration.html ?

Also set SDLOG_MODE to 2 to enable logging from boot until shutdown

You set CBRK_SUPPLY_CHK, so this check is disabled