Cube Orange (flashing firmware with QGC)

I have a Cube Orange, and I am trying to upload PX4 firmware with QGC, but unsuccessful.
When I upload “cubepilot_cubeorange_default.px4” via QGC, device COM ports are not working properly as you can see on the picture. I have a daily build of QGC.
Mavlink COM port is only working if I flash Ardupilot firmware to Cube Orange.

What can I do?
Thanks in advance!


I had some driver issues too in the past. I’m not sure you have the same problem but it look similar. These were my notes:

  • Connecting cube orange
  • Device manager: Uninstalling cube orange device (with driver) and bootloader device (without driver)
  • Installing latest Mission Planner (not just drivers)
  • Connect cube orange again, now works

Thank you! That worked for me.
Can you confirm from which PX4 firmware version is Cube Orange supported ?

The PX4 project currently doesn’t support it formally:

I’m hoping that with enough users, the manufacturer will devote time to PX4 support, documentation and testing.


I have this problem for quite some time and can’t resolve it. I just tried what you explained above, however I still get the following error messages.

Any idea?

I am facing the same issue since last week with cube-orange. Did you find a solution for this issue?

Try uploading px4 firmware with Mission Planner by clicking on “load custom firmware”,
then you can work with QGC. That’s what I did.

I’m surprised that this is still an issue. what a pain.

I never heard of Mission planner working with Px4 on a CUBE Orange. I know that Mission planner works only with ArduPilot . Can you please share a link …thank you