[SOLVED] Airspeed sensor not recognized - tab missing in QGC

Hello everyone,

I have a problem with airspeed sensor, out of the 5 pixhawk I have, only 1 recognize it. In QGC in the sensor tab I don’t have anything about airspeed (only when connected to the “good” pixhawk).

The airspeed sensor is a JMT F19129/30, and the pixhawk tested are version 2 (cube) and Pixhawk 4. The fact that it works well on a cube show that the airspeed sensor works. I use the latest stable version of PX4, QGC is up to date. Circuit breaker for airspeed is 0.

After hours of research I don’t know where to look. If someone has any idea on this problem, any help would be greatly appreciated.

Thanks a lot in advance !
Olivier

Check the settings of the FW_ARSP_MODE and CBRK_AIRSPD_CHK parameters such that they indicate you want to use an airspeed sensor.

1 Like

Thanks for the reply! However I don’t have any parameter named FW_ARSP_MODE.


CBRK_AIRSPD_CHK is set to 0.

I double checked that I had the latest version of px4 (V1.8.2).

Any idea ?
Thanks !

  • What version firmware are you using?
  • What airframe type did you choose?
  • What Bootloader version shows up during firmware upgrade?
  • Have you tried loading the Developer (master) version?

Good luck.

1 Like

Thank you so much !!! The airframe was the problem. I have to admit that I feel a bit stupid, it was a custom airframe which my company configured, and nobody thought to check that. Going back to a default airframe enabled airspeed.

Again thank you for your time !

Hi there, I have a similar problem in which I am trying to use an airspeed sensor for a Holybro s500 quadcopter. It seems that the airspeed sensor tab is not displayed for this configuration. Is there any way to still use the airspeed sensor with a quadcopter using QGC or do I have to use an Arduino to read in the airspeed values instead. I am using the MEAS MS4525DO pitot tube airspeed sensor plugged into the I2C port on the Pixhawk 4.