Airspeed sensor not found

I just downloaded the latest version of QGC and when trying to calibrate the airspeed sensor (Pitot tube) I’m just getting an error message saying airspeed sensor not found! THis didn’t happen before, using the previous QGC version.


Many Thanks.

1 Like
  • What make and model airspeed sensor are you using?
  • What version Pixhawk are you using?
  • What’s the bootloader version of your Pixhawk?
  • What version firmware did you install?
  • Which firmware version did the airspeed sensor work with if you had previously used it?
  • Have you tried loading the Developer version?
  • Have you tried swapping the middle 2 wires?

Good luck.

Hi @rollys,

Thanks for responding to my post. Below are the answers to your questions:

  1. I am using a 3DR Airspeed Sensor with Pitot static tube v1.1. 452500. Use with I2C expansion. (Please see images)

  2. I am using a Pixhawk Mini PX4 FMU V2

  3. Bootloader version: 4, Board ID: 9

  4. Current firmware version: Can’t seem to check. Also when I try to update firmware, I get the following message saying " Downloading firmware…
    Error during download. Error: 4
    Upgrade cancelled"

  5. Previous firmware version: Didn’t make note of it so I can’t remember which one.

  6. I haven’t tried the developer version.

  7. Which 2 wires are you referring to?

Also I’m usiing the QGroundControl v3.4.4

Hope you can find an answer. Thanks.

@rollys More Images


Here is an image of the airspeed error and firmware update cancellation.

From what I can tell, your Pixhawk has an older bootloader so it only loads the V2 firmware instead of the V3. From my understanding, some drivers were removed in the V2 in order to keep the stack under the 1MB limit vs. the V3 that can be up to 2MB.

So you can try to do one of three things:

  • Download and save the V3 PX4 file and load it as a Custom firmware.
  • Try loading the Developer version and see if that recognizes it or
  • Read through the Bootloader Update procedure then try loading the Stable version.

Good luck.

Hi @rollys

None of that seemed to work.

Furthermore, when the pixhawk is plugged-in the QGC goes into an annoying loop of “Manual control lost” and the voice over keep on saying that constantly.

The SCL and SDA wires.

But before you do that, remove the I2C Hub and plug the AS directly to the Pixhawk and see if it works. If it doesn’t, then swap the wire. If that still doesn’t work, then it’s possible that your AS is defective.

Good luck.

That’s usually caused by the Tx being too close to the Rx and it’s “swamping” it. Moving the Tx a couple of feet or so away will usually stop that.

Good luck.

Hi @rollys

Thanks for the tips. I’ll check these out. Well actually when I opened QGC and the annoying “manual control lost” voice over was occurring, the tx was not connected at all.

I’ll check this out today and get back to you, to see if the issues have been fixed.