Sensor issues


after calibrating compass, gyro and accelerometer, i tired ‘Level Horizon’ but the only message i get is:

Start the individual calibration steps by clicking one of the buttons to the left.
[cal] calibration started: 2 level
attitude estimator not running - check system boo
[cal] calibration failed: level

can someone help point me to the solution?

another point: Airspeed is also red, but i have no airspeed sensor. is there a way to disable ‘airspeed?’

using pixRacer, dev-master and qGroundControl (daily build)

thx, alex

There is a parameter circuit breaker for airspeed sensor. Search for airspeed in parameters.

1 Like

THX. And how can i solve this attitude thing?

@alexf Sounds like your sensors are broken. What kind of hardware are you running?

guess what, the cheap clones from china of pixRacer. Is there anything i can do with this clones or is this useless crap?

is there a possibility to check the hardware for functionality?

is there a way how i can verify this?


@alexf Any luck figuring this out? I am having the same problem with my 3DR Pixhawk. It is a genuine Pixhawk and I have not done anything to it except flash it with QGroundControl, so the hardware should be fine.


I’ve added a software workaround for Pixracer. @jmcwil If this happens on Pixhawk it suggests it has a hardware issue.

@LorenzMeier @alexf I just got the same issue on the Pixhawk (from an Iris)

It came from updating the software from PX4 1.5.5 to PX4 1.6.5.

I tried to reset all params, recalibrate, … nothing changes.

The “solution” I found is to fully reset the copter:

  • Send the APM Firmware
  • Send the PX4 Firmware
  • Works

It seems that the problem could come from the EKF_AID_MASK, where I checked the Vision Position Fusion checkbox without using the Vision.



Have the same problem with CUAV Pixhack v3 . “Attitude estimator not running - check system boo” in Level Horizon.

Also accel calibration fails. Every step goes right, but in the end a big log text appears, and the last string - calibration fail.

Is there any information about this flight controller setup?

For me it´s the same with OmnibusF4SD it seems that the whole ekf2 estimator group is completely missing. Using it with a generic quadcopter and LPE estimator the callibration works perfectly except the baro altitude estimation (but all sensors display proper values in nsh sensors status).
I´m trying to build very small tailsitter vtols (two motors two servos) sub 80g

attitude_estimator_q start did it partially only for generic flying wing. After various tries it boots with caipiroshca duo tailsitter and ekf2 estimator … expect baro - and it is has to be typed in nearly after each boot to keep att estimator running

hi i have the same problem.I dont have airspeed sensor,how did you solve it?thanks

I tried the steps explained by @AlexisTM, basically flashing APM and then PX4 Firmware. That solved several issues for me, namely

  • Level Horizon “calibration failed: level”
  • Detected 0 radio channels. To operate PX4, you need at least 5 channels

So what I did was, following the Intel Aero initial setup instructions:

cd /etc/aerofc/ardupilot/
sudo arducopter-aerofc-v1.px4

Wait some minutes for the firmware to be flashed, and then:

cd /etc/aerofc/px4/
sudo nuttx-aerofc-v1-default.px4

Note: I had to add sudo, otherwise it would not work. After this my drone, an Intel Aero RTF, worked correctly.

1 Like

Hi I had the same issues but I resolved it by setting the multicopter estimator group.

on GGC go to vehicle setup, then parameters then search for

SYS_MC_EST_GROUP then change the parameter to
Local_position_estimator, attitude_estimator_q (unsupported)