Missing parameter: FW_ARSP_MODE and CBRK_AIRSPD_CHK for advance_plane

Hi, I am new and I would like to control to advance_plane in gazebo with using QGroundControl but I get an error:

FactPanelControllerLog: Missing parameter: "1:FW_ARSP_MODE"
FactPanelControllerLog: Missing parameter: "1:CBRK_AIRSPD_CHK"

What parameter should I change? Thank you.

I too have lost these two parameters; if you manage to solve it, please let me know

+1 here, I am getting a FW_ARSP_MODE missing parameter.
Pixhawk 2.4.8 and QGroundControl v. 4.3.0 (latest stable I think), fixed-wing config (Generic Standard Plane), AirSpeed sensor connected

Same here too. Tried to upload standard PX4 onto a 3dr pixhawk

I have exactly this same error.

Note: checking this post, it might be the reason: [SOLVED] Airspeed sensor not recognized - tab missing in QGC - #5 by oliverSKP

I kept digging, and I think my Pixhawk has a FMUv2 (helpful: FMU v2.4.8 vs V4.3.6 & V4.3.7, Firmware location and more )…
Is this getting discontinued, and might it be because of that -in my case at least?

I also found in the repository these parameters, but only in the file https://github.com/PX4/PX4-Autopilot/blob/926e7878afc6ce804b0b4c097fbf94d405841f42/src/lib/parameters/param_translation.cpp, the following comments there
// 2023-12-06: translate and invert FW_ARSP_MODE-> FW_USE_AIRSPD
// 2023-12-06: translate CBRK_AIRSPD_CHK-> SYS_HAS_NUM_ASPD
These seem to be detected and, afterwards, param_modify_on_import_ret is called…
Do I understand right and these params are being replaced when imported?

Are our Pixhawks/etc expecting deprecated/nonexistent parameters, and might that be the reason why these are not in QGroundControl?

Mates, following my previous exploration, I searched in the documentation for the parameters, both in the current, where these both are missing, and in a couple of old ones, v.1.13 and v.1.11, where both are present.

I tried to build the FW, but some issues, so, I opted for searching for the firmware for these old versions published in the official repository: https://github.com/PX4/PX4-Autopilot/releases/tag/v1.13.3 and v1.11.3.
Once downloaded these for the right FMU and airframe, let’s say px4_fmu-v2_fixedwing.px4, in QGroundControl/Firmware Setup, you can select advanced tab, and select “Custom firmware file”.

I tested both v.1.11.3 and v.1.13.3, and in both of these I double checked both parameters are present.

*As a side note: V. 1.11.3 sensors calibration seems more slow, but I could calibrate the Airspeed sensor, although the result seemed not stable… same regarding the compass, both were not stable and oscillating without a reason… *
In v.1.13.3, the general calibration process seems improved, compass stable, but I am having trouble to calibrate the Airspeed sensor, the process fails all the time. [Edit] Airspeed sensor needs to be enabled: Airspeed Calibration | PX4 Guide (main) … I enabled the model I am using, and I could calibrate it nicely. All works well.

Summarising: using an old firmware, if I understood right, from 1.11 (apparently when airspeed sensors started to be supported) to 1.13 that is the way to get these parameters listed again, so, just downgrading to the previous version.

I hope it helps

1 Like