SIK Radio Telemetry - Very slow - Removing ECC made big difference

Hello

We have been suffering very slow connection rates with SIK Radio Telemetry, upwards of 30s for the initial parameter download. We are using them in a Pixhawk2.1 with 1.7.3 firmware.

Last time we used these radios it was in a Pixhawk 1 ( we have been using pixracers in the in between period) and I remember having a reasonable quick parameter download then.

I have read in some Ardupilot forums that ECC was related to the issue,


So have disabled it setting
ATS5=0
as explained here:
https://dev.px4.io/en/data_links/sik_radio.html

This has made a huge difference, now parameter download takes less than a couple of seconds…

Of course disabling ECC (Error correction checking) is a bit of a worry, so just wondering:
Anyone has experience disabling ECC ?

Another suggestion in threads is to keep ECC enabled but reducing the serial baudrate to half of the airdate ( ECC increases the amount of data sent apparently).
However I’m reluctant to do that as I don’t know how to change baud rate in QGControl or wether it as autodetect?
Any thoughts on this second option ?

Lastly I’m wondering it this issue has just appeared because the volume of mavlink data been sent is much larger? We are using more sensors now. … vision navigation, px4flow

Is this issue ever solved ?
I have mounted 4 TF-luna’s and since then Telem 2 is fully occupied.I moved the Luna’s (lidars ) to telem 1.
The luna’s work fine on Telem 1 , but not on Telem 2.
And now i cannot connect Minimosd to Telem 2 because of this slow data rate.(on the Pixhawk port Telem 2)

No-ECC