S500 / PixHawk 4 / px4: New build does not start

Hi,

I’m new to building quadcopters and assembled a Holybro S500 kit with PixHawk 4. Everything worked straight forward. But my maiden flight yesterday was no success.

The copter just wobbled on the ground and did not lift off. I started in “stabilized” mode.

So the main thing that was not really clear to me, was the motor configuration. I followed the guide here an my wiring looks like in this diagram:


Unfortunately, you can’t spin up motors in Qgroundcontrol with px4 1.10.1, there is a bug. So I decided to flash ArduPilot. And there motors behaived very wired. I figured out how to wire up the right order with ArduPilot.

Then I decided to flash the px4 Mainbaranch. Motor spinning works there. Again, the order was conpletely wired. I did build it back (Motor#1 to Output#1, Motor#2 to Output#2…). Now it looks again like in this diagram, and I found this pic in the Doc, where wiring looks similar to mine:

.

Mhh, looks like I was right in the first time. And I flashed back to the stable version of px4. ArduPilot an px4 seem to have different motor mappings.

Also, my motors are spinning to the right direction.

So what could be the problem?

Is my motor setup OK?

Maybe a smaller Lipo (actual: S4-5500mAh, about 500Gramm)?

A better ground to liftoff (started on a plown field)?

First trys with AutoLiftOff and AutoLand?

Lot of questions. Thank you for your help

Manfred

I can’t speak to ArduPilot, but if you load 1.11 beta of pix4 the motor test command will work.
You need to push the safety switch on the GPS.
I also recommend that you start up in attitude or position mode. You can use the Arm slider in the UI or use the stick to start up. I would not use auto takeoff until you see that things are right.
Yes your motors look right.

Also if you plug the I/O PWM out on the FC to the FMU PWM IN you can get rid of the little break out board and use the FMU PWM out connectors.
If you do go back to Pix4 I can help as I just got this one working fine.

Hi and thank you for your help.

I flashed 1.11 Beta. My motor setup is now as follows:

Slider 1 > front_right : ccw
Slider 2 > back_left : ccw
Slider 3 > front_left : cw
Slider 4 > back_right : cw

I bought a 3S 3000mAh Lipo, which is half the weight of the 4S

I hope I can make a new try this evening. This time with alt/pos mode.

Maidenflight #2:

It just did not liftoff. Seens that the 3S 3000mAh is not enough.

Maidenflight #3:

I recalibrated everything, and also went back to my 4S 5500mAh Lipo. The Quad lifts off from the ground, Motors are spinning faster. But it always drifts to a site and comes down.

Here is a little vid. I did this with auto liftoff, but doing it by hand, has the same result:

I really have no more ideas how to debug this.

Finally I found the bug.

I mounted the Pixhawk with a centered strap of velcro. This gave it some space to circle arond his own axis. I thought this would be a good idea, some kind of soft mounting. But it was to much.

Now I have a velcro strap catching all corners of the Pixhawk - and it is flying :sunglasses:

Glad to hear that. Yes, the FC needs to stay in position and be sure the arrows on the GPS and FC point the same way,
My S500 flies just fine with 3S.