Motor Test Command Denied

I couldn’t find any solution for this problem , also didn’t see anyone has same problem. Some of talked about “motor command not supported” but in my case “Motor Test Command Denied”. Anyone has an idea or faced with this problem before ?

2 Likes

Yeah, I get the same error message…! They say it was going to work in the next release but that never happened, just like their so-called SUPPORT, that’s a big nothing tooo…!!! =)

Did you manage the problem ? And I am not sure about if the problem is QGC or PX4 versions. Did you try previous versions also ?

No I have not managed the problem, neither has anyone else to my knowledge. From what I’ve seen here they just discuss stuff… unless someone happens to know something, otherwise nothing ever gets fixed. I have no idea why it’s called a Support Forum. I think the problem is with QGC… not PX4, it was not present in Previous versions that I recall. Lot’s of people complained it didn’t work, nothing done about it, it still doesn’t work…! Wish I could help ya out bud… but you see here, no one replied that is affiliated with Forum, I’m just a some what user like you looking for answers, never found any here…!

Thank you ,at least I have learned that there is no solution so far . I am new in drones and starting academic research about power characteristics about drones. So I need a familiar program like QGC . Do you have any suggestions ?

Aziz; I am new to drones also been building this one for 2 years now, never finding any solutions to anything or problems I’ve run into, so welcome to the club…! My first mistake was buying a Chynese Clone Pixhawk Flight Controller to save $, that didn’t work, so $76.00 down the drain. Everyone boasted about Holybro products, so I spent $227.95 on a HB Pixhawk 4 Flight Controller and still nothing works…! QGC was boasted about a lot too, but it’s where all my problems came from with, Quad Copter would not arm, see the Console…! In the Console was at least 3 errors, I have no idea what the errors mean, no references any where about them, forums couldn’t reply with any thing good/bad, so Today I erased QGC and downloaded Mission Planner…! Everyone boasts about it too, so I’m giving it try…! In both GC’s the firmware loads and applies w/out any problems, the Configuration’s both go great as well… Still no ARMing of the Controller and w/out Arming there’s no Flight…? From day one, I’ve used QGC…so now I have to get into the Mission Planner program because they’re both different…! There’s YouTube videos on both plus detailed instructions at the respective sites… so hopefully it just a matter of time…?
James…

We have solved the problem. Just need to attach GPS module on Pixhawk and click on safety swtich. After that you can control motors and no more “Motor command denied” It is working now . I hope you can also solve the problem with this way. I think QGC should indicate that safety switch should be clicked and hold on like 3 second then the led on gps will blink faster and you will be able to run the motors.

3 Likes

Aziz; I tried it today like you said but mine didn’t work…glad you had it working for you, I must have other problems some where else…?
James…

I also changed to drone airframe it was like quad copter but to be sure there is no problem I changed to helicopter and run only one motor. So my test system doesn’t have to fly I just measure , rpm and thrust with some external sensor. Also be sure drone is armed mod and in my case I use manual flight mode.

hello i have the same problem my gps is attached to the fc …where is the safety switch ???

hello i have the same problem motor cannot do the rotation test error motor denied …
The remote i using skydroid T10 the throttle return is centre point n start point in centre …how do i do the setting in fc …tq

The safety switch is by the leds it’s hard to see it but it is there, if you have the correct GPS the the larger plug on it.

2 Likes

safety switch is also a led on GPS module , clickable led marked as ''SWITCH" on GPS module. Just click and wait 3 - 5 seconds until led blink faster.

1 Like

hello friend …tqvm …i also build one unit dji naza v2 much more easy setup than this pixhawk
i need your help for the setup can you help me online with teamviewer and im from malaysia and you??

Thank you

hello friend my remote is skydroid T10 the throttle lever is centre start point …how do i setup this in px4 …error throttle too high …tq

Still going through the same old “Denied” crap…it Says in the Flight Controllers Message area, "denied because it is “Not safe to fly with the USB Cable Attached to the Flight Controller…!”
And here it is December 2020 and no one has had time to assess, look, or study a solution…! So I want to thank you all for destroying my Quad Propeller Tips because my Quad flips over on to it’s back at TAKE OFF…! Maybe you should all just over to Github and goof off over there, they have 844 Issues with QGC…! None are fixed yet… “Support” what a freaking joke…! =(

You dont need the GPS module or sth. I just pulled safety switch, pressed on it and tehn modev the motor bar up. It worked.

I’m another newcomer, having the same problems with GGroundControl and getting permission to test spin the motors on my hexacopter build.

Sad to see this issue hasn’t been actively discussed for months.

I’m asking questions about in two other subcategories here.
So far, no responses, not even a “stop cross-posting” message from the admins.

“Not safe to fly with USB” I get the same message! What do I DO with that?

When I try to Calibrate the Joysticks on the X9D using QGC, I also get
“0 channels detected, PixHawk needs at least 5”

I have 8 channels configured on the X9D.

It seems GGC can’t “hear” my Taranis X9D Transmitter, aka RC Controller. I wish someone knowledgeable would comment here on my SWAG (Scientific Wild-Ass Guess).

I am getting good signal strength readings on the X9D from the aircraft radios.
It’s been very difficult to find any detailed information about what hardware QGC expects to have in order to function. WiFi apparently can’t talk to RC radios?

Responding to my own post.

I am pursuing the idea that the Receiver onboard
is not being detected by the PixHawk 2.4.8

Is QGC receiving this message via MavLink from the PixHawk?
How? via WiFi? I don’t know.

That would explain QCC reporting “0 channels detected. PixHawk needs at least 5”

I had assumed that IF the X9D was getting good RSSI
signal from the onboard Receivers, they must be communicating
with the PixHawk. I will have to find some way to verify this.

The instructions I can find for my Receivers tell me to plug the Receiver SBus Out
to the PixHawk RC In terminals observing polarity on the - + s pins

PixHawk is either Okay with that or doesn’t notice/care. The Receiver is getting power,
so - and + are present. Perhaps the Signal part is not right.

I am digging deep into the inner workings of the board and its firmware now.
It is a clone, has FMU v2.4.8 screen printed directly on the circuit board.

That might imply it’s somehow an upgrade from the official PixHawk Standard
FMU v2.4.x (haven’t verified latest version yet) Seems to accept 2Mb firmware file size.

More later.

Today I learned that ONLY FrSky Receivers INVERT the SBus signal.

Apparently newer flight controllers have the necessary UN-inverters built right in, solving the issue. That’s probably why this issue is not common knowledge…everyone at the bleeding edge of RC tech.

'Tribal Knowledge" of the older hardware must be fading out slowly…or I’m sure someone would have jumped right in and mentioned it.

My PixHawk 2.4.8 is older and apparently does NOT have the built-in UN-inverter.

Tutorial link here : Uninverted SBUS and Smart Port on Frsky Receivers - Oscar Liang

I am pursuing the hardware hack option. Locate non-inverted signal on the circuit board of the Receiver, wire that to SBus Signal pin of Receiver.

I’ll report back on results.