Motor doesnt response

Hi, I have been new in drone. For my project I am using Holybro X500 kit. From the kit I got drone motor, propeller, power management board and other necessary parts. For assemble purpose I have followed Holybro X500 + Pixhawk4 Build from this link: Holybro X500 + Pixhawk4 Build | PX4 User Guide
I also followed this tutorial series for assemble purpose. I have calibrated PX4 stack for my drone. As per documents I should get some sounds if ESC and motors are connected properly. I have got that sound as well. But the problem is my drone motors are not responding againts any action of my remote control or motor testing in PX4. Here are some pictures of my drone assemble and calibration



Furthermore every time I got this error "preflight failed. compass number 1 uncalibrated’. Can anyone recommend me anything that I have missed may be or what could be the solution of this problem? Thank you.

Are you sure that the FC is pointing in the correct direction.
Can you see the compass in QGC and does it seem to point in the correct direction.
The arrow on the FC needs to point in the correct direction as does the arrow on the GPS.
How are you arming it? Until it is armed the motors will not spin.

According to the documentation I assembled FC and GPS in the same direction. Is it not correct what showing in my previous picture? I can see the compass in QGC and but when I try to initiate arming I got this error “Preflight check failed, compass number 1 uncalibrated” and “Preflight check failed, not enough GPS satelites”


Again in QGC at arming status I got this one,. What did I miss for this error? Arm
For motor testing, if I enable motor testing switch and move the motors sliders I got this errir

hello i see your direction fc and gps is ok …you have low gps signal 5 is low friend, get the gps signal good first than do calibration again …please do it outside house away from any metal …something to do with your setting this error unable to command : waiting for previous respond is the software new QGC problem …i had the same problem i install the 4.0.10 works well if you need help futher i can helps to check online tv …i had so much problem with pixhawk 4 and pixhawk 4 mini final this error and failures able to get it flying

Dear Danial, Thank you for your support and advice. I calibrated pixhawk compass outside home in an open space but still it’s having the same issue. I got the same error " Arming denied, preflight failed. compass number 1 uncalibrated". and like before “GPS, AHRS, Pre-Arm Check”-error. I understand due to preflight failure drone arming denied. But does it mean that still my calibration is not enough? I have installed QGC stable 4.1. does the error have any dependency on the version?
I haven’t found 4.0.10 for installation. I have been stuck in this issue for long time. I need to solve this issue for my further process. I will be highly privileged of having any help from you. Thank you.

finally solved this problem…fault was with esc signal wire and motor terminal M1/M2/M3/M4 and firmware updated …test arm now it works well no more error