RSSI stays at 100% (Pixracer)

Hi everyone,

I received my Pixracer about a week ago and put it onto a simple ZMR250 clone that I had lying around for figuring out the first steps (I want to use it on a larger scale quad later on but also have ordered most parts for the Caipiroshka VTOL, I guess I’ll have to make up my mind or get two :wink:). So far, most things seem pretty well, although my first indoor maiden showed I’ll have to tweak the PID defaults a bit before going for the first real maiden flight. I have the PX4 master build on it (installed a few days back).

One thing I noticed is that RSSI does not seem to pick up. I am using a D4R-II on a modded Turnigy 9x (with ER9x). I have both connected the RSSI_IN pin of the Pixracers RC port to the D4R-II’s corresponding output for RSSI and have also connected the FrSky telemetry in/out ports (and basic telemetry data like Voltage, Current and GPS is passed down to the transmitter).

If I check in QGC, the RSSI value however always remains at 100%. I tried it also with the RSSI_IN disconnected (figuring it might get transmitted via the Telemetry Input from D4R-II to Pixracer?) and I even connected a servo tester to the RSSI_IN pin to see whether it reacts on a PWM signal - nothing.

Am I missing some setting, am I on the wrong track or is this not yet supported?

Thanks a lot and keep up the great work!


I have done some more homework:

  • apparently, the D4R-II doesn’t send a regular servo-timing-PWM output but a higher frequency PWM signal (should have googled a bit more up front). Then again, the page at indicates that “RSSI can be provided as analog input on the PIXHAWK SBUS port if SBUS out is not used.” and due to the mentioned low pass filter this should be possible to evaluate - I hooked up the D4R-II’s RSSI out channel to a multimeter and received smoothed values between 1.x-3.2 volts depending on signal level so it should work, right?

  • To make sure it’s not a QGC bug I checked a flight log but RC.RSSI stays at a straight 100 line

  • I found parameter PWM_SBUS_MODE in and I assume it would need to be set to 0 for the above to work, but my log shows it is set to 1 currently - that might be the reason. But I can’t find it in the QGC parameter list?!

Is there a way to manually set PWM_SBUS_MODE to 0 via QGC or another tool?

Thanks again,

@Zimbo Its not implemented yet. @Mark_Whitehorn is the person to talk to for RSSI.

I’m currently using the built-in FrSky telemetry for RSSI, and logging it in my Taranis TX. With SBUS input, the PX4 firmware detects RC signal loss via a status bit in the data stream, so RSSI isn’t necessary for failsafe. So analog RSSI input is not high on my list of priorities.

@Mark_Whitehorn Thanks for the feedback - I already found in the code that there is no implementation and figured it’s rather low prio given that many people are on SBUS, HOTT or similar, but I spent so much time modding my Turnigy 9x with D-style telemetry that I want to use it now :slight_smile:

I am actually currently looking into giving it a try in a fork and implementing it myself to also get up to speed in developing in this environment (after a quick check, it seems it’s on pin PC1 / ADC123_IN11 on the racer and I could pretty much steal from the code that was given in the pixhawk’s px4iofirmware/controls.c implementation for ADC_RSSI). But my C is a bit rusty and time is limited between family, flying and coding, so let’s see…

It sounds like you know what you’re doing. How do you want to use RSSI? Doesn’t your TX module beep when it starts getting low?

@Mark_Whitehorn, today my QGC (Windows & Android) stopped to show RSSI. I’m using Taranis + X4RSB and SBUS protocol.

It was working (I think so) in the previous versions of QGC or PX4 firmware. I have installed today the latest build (master) of QGC and PX4 firmware.

@LorenzMeier I don’t think I’ve ever seen that message before. The only RSSI values I currently use are those reported by my Taranis TX. I’ve never tried the “analog” RSSI inputs.

@marimach77 I think the best place to ask this question would be!forum/qgroundcontrol
I’d have to ask there or look at the source code to figure out where that message is coming from.

@Mark_Whitehorn, thanks for info. Alreayd posted my question here!topic/qgroundcontrol/wpf9h0K9pYQ

@marimach77 S.BUS does not actually provide RSSI. So what you saw before was incorrect and what you see now is accurate.

Hmm… strange but ok. You could be right.

By the way: analog RSSI is working in the meantime thanks to Lorenz IIRC - thanks guys!

Ahhh… to get RSSI from X4RSB I need to solder short cable to RSSI pad.

Can I just connect receiver Smart Port to Pixracer to get RSSI too?

1 Like