PixRacer FrSky Telemetry including GPS

#1

Hello!

A question for you.

I have connected the Pixracer FrSky Telemetry port to X4r-SB Smart port.
I can confirm on the Taranis Plus that is receive 18 parameter when the Telemetry port is connected, and maybe 4-5 when the telemetry port is not connected.

When connected, I get:

  • A2
  • SWR
  • RSSI
  • RxBt
  • VSpd
  • Hdg
  • GAlt
  • GSpd
  • Date
  • GPS
  • Curr
  • Alt
  • GSpd
  • VSpd
  • Fuel
  • 5000
  • VFAS
  • 5001

They blink (with an asterisk) when they update, but i am unable to get the GPS coordinates to Show on Taranis.

I have a 3DR NEO-7 GPS with a 3D fix, confirmed in QGC and the Airplane logo follows properly…

Does Pixracer relay the GPS infos (Coordinates, and more) to through the FrSky Telemetryport?

The Taranis Logs show nothing for GPS Telemetry

Note: i was not armed, does that change something?

I am running 1.41 RC2, will update to Full 1.41 soon to test again.

Thanks

NJ

#2

Did you do the test outdoors?

#3

Yes, I was outside locked with multiple GPS.

I Updated tonight from 1.4.1RC2 to 1.41 Release

Here is my Taranis Telemetry sensors Page: (Running 1.41 Released)

Notice Sensor#6 (GAlt) = 4.6Km, Hmmm Strange
See also Sensor#12 (Datet) = Garbled = 55-182-7 00:00:00

Other values provided
See, now at 36Km altitude??? (Below)

and other Date weird Values below , see GPS is Blank (Note i got the GPS West Value to show once, but North value was zero)

I see the Asterisk Blinking tied to the Date Weird Value Change, can this be a faulty GPS? cabling? Baud rate? Bad RX (X4R-SB)?

Any recommendation?

Thanks! NJ

#4

Tested same Kit with an other RX (XSR) with Same Taranis same result

Forgot to say that the GPS is 3DR NEO-7 and Blinks Blue while tests are occuring.

Should i try PX4 Firmware 1.3.4 ? Never tried it…

#5

Continuing to test different aspect of this.

Looked at QGC while i had a GPS lock (GPS was in indoor in a Window)

I have a 3D lock, but getting all sort of values “LPE - GPS FAULT”

What does that mean? See image below…

#6

Your GPS lock is very sketchy and not offering a good position estimate. The system detects this and tells you.

#7

Could this be the cause to my telemetry issue?

Although I never had a proper GPS Telemetry on Taranis

When, except from the Critical Messages Above, QGC is happy with the GPS position

#8

@thedevleon Should GPS lat/lon display properly on a Taranis without your custom script?

#9

Was telemetry reception via FrSky port really as straightforward as appears above?
I have two Pixracers, each with an X6R FrSky receiver.I am using an X9D transmitter, with up to date firmware.
I get NADA. No new telemetry discovered.
I have read various suggestions that, for example, I need to configure the relevant serial port, none of which helped. I had assumed with the FrSky port inbuilt that it would pop up without any configuration. Is that what you found?
With one Pixracer, I would be suspecting faults, but not with two.

#10

This is a very late answer so I sincerely hope you already have it working well. I have a Taranis Q7S connected to R-SXR and X8R receivers and have used wiring shown here: https://docs.px4.io/en/peripherals/frsky_telemetry.html (there is a sketch for Pixracer and X8R). My Pixracer is bought from mRobotics and I also have used Chinese clones and the radio discovers almost all possible values immediately. Only the 0420 item (distace to home) is missing right now.