Pixracer and FrSky telem port No joy. Using QGroundControl

#1

I have two Pixracers. They work OK but I get no FrSky telemetry. I had imagined it to be defaulted to work, but apparently not. Wiring checked twice.I have the latest QGC at V 3.4.1 and just updated the firmware on one pixracer to ensure it was up to date.
I have run round in circles on the 'net and keep looking over my shoulder to see if I am about catch up with myself - or so it feels like!
Each piece of likely looking advice seems to dead end
e.g. reference to FRSKY_TELEMETRY - this does not display in QGC’s param list
Serial does not show in the param list as a heading though I have seen it in Web images. (Important I imagine)
I saw a reference to needing to adjust a GPS tab (to enable Serial, if I remember) ? -but the suggested parameter was not present. I have heard of “loading drivers” to get missing parameters to show, but this is an up to date Pixhawk with an FrSky inbuilt port. Surely I do not need to add extra firmware??
Not really sure if I should blame QGC or the Pixhawk.
I came accross a reference to such a problem on Github with a promise to fix it. That was dated about 10 months ago. I have to assume a fix was created by now - there must be loads of Pixhawks out there wanting to use FrSKy telemetry.
I am building a quad for my son, and promised him a load of lovely telemetry data, so I am honour bound to succeed!

I am missing a key piece of info/advice. Anyone had this knotty problem? Save my sanity please.

1 Like
#2

Have you read through the documentation and also have the appropriate cable? Also, you need to use the Developer version of v 1.8 firmware.

Good luck.

#3

Delighted to get a response. Been wringing my hands.
Yes, I have read the documentation you point to.
Hand made cables (two off for 2 Pixracers) double checked.
Assuming I had an appropriate firware with the delivered goods, and overwrote this.
Visited GitHub to look for the “developer version” of firmware, but found nothing under that label. I’m not very familair with GitHub however. Should I hang onto the “developer” handle while searching GitHub? I see V 1.8.1 stable - good enough do you think?
I’m another of those enthusiasts who took up radio control, only to discover later that you really need a University course to understand everything.
I have to believe it’s a question of the correct firmware, but where is the little bugger to be found?

#4

Choose the Developer version option from QroundControl. That’s the one that works for now. I do believe they’ll incorporate it on the next Stable version.

I do highly recommend signing up (it’s free) on the Slack forum to request for immediate support.

Good luck.

#5

Hello. Are you using the R (long range) series of Frsky? If yes, it really was not working. I tried with several Frsky receivers. The X4R worked well. Let me know if you need more explanations. :+1:

#6

Using X6R for both drones.
I’ll take up your advice re Slack Forum.
Appreciated your help -thanks,

#7

Hello. I’m using firmware “ArduCopter 3.6 Stable” in a Pixracer R14 connected to X4RSB (X4R with SBus) and telemetry worked perfectly. I’ve just tested with firmware “PX4 1.8.1” and telemetry is okay as well. So, using PX4, after initial basic setup, I’ve just connected the cables and Taranis discovered 16 sensors. I did not configure any telemetry parameter. If you are using Arducopter, you must set the SERIAL4_PROTOCOL to 4. Please, check you firmware version and lets go on.

#8

I’ve got gremlins. I’m sure that is the problem!
e.g. I was informed theQGC megaphone symbol would tell me the current firmware version. All I get is a blank screen.
I re-updated the firmware and managed to capture this info before it vanished:
From: http://px4-travis.s3.amazonaws.com/Firmware/stable/px4fmu-v4_default.px4 and going there I see some problems listed but these are a year old- disregard. So I have no version number for the firmware, just “latest” which is not good enough.
When I search the parameter list for SER_ or TEL_ I get nothing relevant, nothing on Serial, nothing on FrSky/Telemetry.
I’ve been floundering around on GitHub, but you need a brain the size of a planet as Marvin is fond of saying, to complehend what to do with the long lists of obscurely named files there. I kind of assume GitHub is not the place for final firmware but is source files only (?)
Interesting to hear your setup went without problems. Did you use the firmware supplied witin the pixracer, or go for an update immediately, as I did - and probably screwed up somehow at that juncture!
I just updated QGC to 3.2.0, but as expected this did not change anything -“it’s the firware stupid”, but how do I get the firmware I need!
How did you read the firmware version you are using. perhaps I’m missing a trick here?
Thanks for your reply.

#9

Finally got to understand how to “choose the developer version” as suggested by Rollys above, and indeed that does provide an FrSky parameter in QGC. Thanks.