Receiving custom messages via TELEM1

#1

Hello,
First, forgive me if I ask something stupid, I am new to px4 development. I am trying to connect several pixhawk4 controllers in series using TELEM1 as input and TELEM2 as output (not using mavlink but raw read/writes). TELEM2 seems to work fine both as input and output, but TELEM1 is sending a lot of data that has nothing to do with my code… my guess is that Mavlink uses TELEM1 to send telemetry data.

Is there any way to deactivate this or remap the port used by Mavlink?

Thank you very much
Borja

#2

Try this to disable mavlink on Telem1:
https://docs.px4.io/en/peripherals/serial_configuration.html#default_port_mapping

#3

Thanks for the answer. Which parameter should I modify? I have read all the descriptions and I cannot find out which one disables the use of TELEM1.

I am guessing that changing the parameters from QGround should be done every time I recompile the firmware… where are those parameters stored in the firmware folder structure? So that I don’t need to change them every time I recompile (I am using several pixhawk 4 controllers).

Thanks!

#4

@bkueng you can probably help here, thanks.

#5

Check MAV_0_CONFIG and MAV_1_CONFIG. Once you disabled them they will stay disabled after flashing the Firmware.

#6

I found those parameters, thank you both!