How do I configure which mavlink messages are sent?

#1

My pixhawk is connected to an onboard computer on the TELEM2 port, and to a 915Mhz on TELEM1. If I open the mavlink inspector on QGroundControl with a computer using a 915Mhz radio I can see a local_position message. If I use QGroundControl on the onboard computer connected to TELEM2, I do not see the local_position message. How can I configure which messages are sent over which ports and what their rates are?

I saw here (https://docs.px4.io/en/peripherals/mavlink_peripherals.html) that I can use MAV_0_CONFIG, MODE, and RATE to do this but those parameters are not listed in QGroundControl. Do I need to add these parameters somewhere?

1 Like
#2

Hm, interesting. I think you’re on the right track with these parameters.

Have you tried the parameter search in QGC and typed MAV_0/1/2? They really should just be there, I think.

#3

Thanks for the reply. I tried the parameter search and didn’t see them.

I ended up solving the problem. It turned out that I wasn’t getting the messages I wanted because the baud rate of TELEM2 was set to 57600 instead of 921600. The startup script rcS decides which mode to start mavlink in based on the SYS_COMPANION parameter, which contains the baud rate. Also, to enable specific mavlink messages and rates I guess I could add mavlink commands to the extras.txt file.

#4

@bkueng do these MAV_ config params work?

#5

Yes but you need to use master.

1 Like