Yaw Control not responding

Greetings PX4 experts, my name is Jesus Lopez a current student in CINVESTAV in Mexico, I’m starting in this new world of UAV’s making a VTOL I’ve been working for a while in this fixed wind VTOL using a BIXLER 2 as the body and a structure made of glass fiber and 4 Quantum brushless motors, here is a picture of the aircraft.

I’m using a Pixhawk platform with the latest firmware and I have had some troubles with the yaw control, at first I though it could be a problem with the weight distribution or an miscalculation in the motors’ shaft direction but after measuring the weigh and direction of each motor but I continued having the same issue. After tunning the Multicopter PID Roll and Pitch work sweet as cotton and I’ve been able to make some flying test to show you the problem.

Please check the video annotations for details.

I set the 10019 DeadCat parameters because it’s the most similar to the geometry of my VTOL as you can see in this image:

In this link you can see the parameter and the log of this flying test. I tried to upload the log file on the “log uaventure” page but an error appeared for the extension file, I don’t know how to change it to the right extension but I will try to look for it on the QgroundControl.

https://mega.nz/#F!AhUGHA5Q!jANY3Fq_1NxRjuCWLGfqDA

I hope you guys could help me to find out whats the problem, thanks in advance.

Hi,

The most likely cause of the yawing is that your yaw gains are either too low or you have tilted the rotor axis of one or more rotors. Even just a 3 degree tilt can completely kill your yaw response.

I suggest you instead do this:

  1. Flash master
  2. Use one of the standard VTOL configs. They have a lot of critical tuning steps done, in particular:
  • Your frame is an X, not a W / deadcat frame
  • Make sure to set MC_YAWRATE_MAX to 20
  • Make sure to set MC_YAWRAUTO_MAX to 20

could you share a log of your flight?
please upload it to http://logs.uaventure.com/

Thanks a lot for the advice, I will set this changes and try another flying test.
You may be right about the tilt rotor, I tried my best leveling the shafts using some aluminiun can layers, here you can see it is not perfectly aligned:

I will double check it before the PID tuning and as soon as I make the test I will share with you the log file.

Again, thanks a lot for the fast reply.