QGroundControl PX4 Arming denied: press safety first

I build S500 V2 model with PX4.
Firmware version 1.10.1

I made all calibrations, all are green.
Connected the 3S 3100mAh battery, fully charged.

When I try to arm with remote control by - put the throttle stick in the bottom right corner.

I get the error “Arming denied: press safety first”.
In the S500 V2 package I didn’t get any safety switch, I don’t have one and I don’t connected any.
Is there any method to arm without the switch?
What is the recommended approach in this case?

The safety switch is actually located on the GPS module next to the “switch” text. There is a clear button that protrudes just a little. I didn’t realize that it was there for quite some time. Also make sure you aren’t attached to your computer. Once you plug in your battery press and hold this switch, then arm your quad, then fly. Good luck!

1 Like

Hi @alexfache, thanks that switch did the job.

What else should I configure on QGroundControll or remote?

I was able to arm the vehicle from computer telemetry connection + pressing the switch.

But I’m not able to arm the drone with remote, by moving the throttle bottom right.
I enabled PPM on remote.
I did the remote calibration, like described here: https://www.youtube.com/watch?v=1IYg5mQdLVI
Throttle respond on PC when I move them, but any response from drone

Good day,
if you are using the receiver with sbus protocol, you must set on your taranis if you own this the mode D16 and rebind it

Glad you got that working! The Arming procedure depends on how you set it up in QGroundControl. Go to the “Flight Modes” page and on the right hand side there will be an option “Arm switch channel”. Here you need to select the channel on your transmitter that maps to the physical arming switch you’ve selected. By toggling this physical switch you’ll arm your quad.

The video you linked just shows you have to bind your receiver not actually how to set up channels.

I actually have some step by step YouTube videos that go through the setup process:
Pixhawk 4 Receiver and Transmitter Configuration
^ this will help you map physical switches to the channels with your transmitter (such as an arm switch).

Pixhawk 4 Setup and Calibration with QGroundControl
^ goes through the entire QGroundControl setup process.

As Dave84 suggested, I also used sbus protocol with the FrSky X8R receiver and Taranis X9D transmitter. It’s a simple setup. Let me know if you have other questions.

1 Like

I have FLYSKY FS-I6 remote with FS-IAS10B receiver.
I used SBUS and PPM cables to connect the receiver, as described in the assembly guide.
Will be good to see what are the configurations that are required to setup the remote control?

For sbus you need the sbus cable(just look the pinout scheme), the vcc snd the gnd…, with a little bit of DIY you can wire it on your fc… what kind of fc are you using?

this are the cables I used to connect reciever:

Thank you guys, for your help.
I was messing around for days because of this configurations.

Witch on GPS + QgroundControl config + FS-I6 remote setup for ARM switch = all did the trick.

For PX4 S500 what is best software to use QGroundControll or Autopilot?

For the receiver just use sbus cable.
For firmware you can choose between px4 or ardupilot…just test both developments and after this you can choose the one that you can find comfortable