QGroundcontrol "Detected 0 radio channels. To operate PX4 you need at least 5 channels"

#1

Dear people

I do have a question about the pixhawk mini and Qgroundcontrol

I wan to calibrate the RC transmitter (Graupner mz-12) and the Receiver (Graupner hott, 2400) by means of Qgroundcontrol under ubuntu 16 over the Pixhawk mini.

According to the following link https://docs.px4.io/en/config/radio.html#spektrum_bind

  • I have connected ch6 from the graupner receiver to the RCIN on the pixhawk mini.

  • I have binded ch1 to ch 5 (transmitter and receiver), and set up to “ON” the RF transmit from ch1 to ch5 on the receiver. In other words, RF sett->rx = R06 (which means is binded) and RF->RF = ON. In every channel from 1-5 and channel 6 is set to “free”

  • Then on my Graupner mz-12 I went into the Telemetry->Settings & Data View menu, scroll to bottom where it says SUMD on ch6 and change to yes

When i click in the radio icon on QGroundcontrol
I always get "detected 0 radio channels. to operate px4 you need at least 5 channels

I upload some pictures of the setup.

"

Thank you very much and
I am looking forward to your replay. and thank you.

#2

Good day,
Spektrum and DSM receivers must connect to a SPKT/DSM input of the pixhawk mini,

PPM-Sum and S.BUS receivers must connect directly to the RC ground, power and signal pins typically labeled RC or RCIN
PPM receivers that have an individual wire for each channel must connect to the RCIN channel via a PPM encoder like this one (PPM-Sum receivers use a single signal wire for all channels).

#3

Hi there,

Thank you for your replay.

You gave me 3 cases.

  1. Spektrum and DSM receivers must connect to a SPKT/DSM input of the pixhawk mini,

  2. PPM-Sum and S.BUS receivers must connect directly to the RC ground, power and signal pins typically labeled RC or RCIN

  3. PPM receivers that have an individual wire for each channel must connect to the RCIN channel via a PPM encoder like this one (PPM-Sum receivers use a single signal wire for all channels).

Which one of the three cases is my case? And, how can I solve it.

Would you mind taking a look at this site

https://www.rcgroups.com/forums/showthread.php?2400871-Configuring-SUM-signal-in-a-Graupner-mz-18-24

It looks similar to my case, but i do not know what im doing wrong :slight_smile:

cheers :slight_smile:

#4

Spektrum and DSM receivers must connect to a SPKT/DSM input of the pixhawk mini, with the appropriate cable, coz the rc in port is different in size.

#5

Hi there

Would you mind explaining more according to my setup

I wan to calibrate the RC transmitter (Graupner mz-12) and the Receiver (Graupner hott, 2400) by means of Qgroundcontrol under ubuntu 16 over the Pixhawk mini.

I mean:

  • settings in the RC transmitter

  • which channel in the RC receiver

  • is there anything I need to set up in the QGroundcontrol

Cheers and thank you

#6

Good day,
if you want use Spektrum and DSM receiver you must first wire it on SPKT/DSM port of the pixhawk mini

#7

Good day,

do you have an schematic on how to wire SUMD from the hott 2400 graupner receiver and the SPKT/DSM port of the pixhawk mini?

Thank you

#8

Its the same like the rc in port but the connector attached on the board is different

#9

I have the same issue with mine. My setup is Pixhawk, Lemonrx plugged into Spektrum/PPM port. Receiver binds fine with my Spektrum DX6 by itself. When I try to bind through QGroundControl, bind fails in any of the three modes. With the rx bound, I get the message that 0 radio channels are detected. What do I do next?

#10

From my experience, I’ve found it best to bind the satellite Rx first with a regular receiver first and test to make sure all outputs are working there. From that point, transfer the satellite Rx to the Pixhawk then do your RC calibration in QGC.

Good luck.

#11

There is a massive hole in my knowledge. I am very new to the drone/quad world. All of my previous RC experience has been in sailboats, and they all use ‘standard’ configuration rx & servos. I have no experience with satellite Rxs. I think I understand that the satellite is bound through another rx with a PPM port. Do both have to be on board, or do I run with the satellite only on the quad after binding? Is there a tutorial somewhere I can read on this? Thanks for putting up with this overly-long post.

#12

If you have the receiver and the satellite rx:

  • Bind the receiver with the satellite rx connected to it.
  • When binding is complete, unplug the satellite rx from the receiver and plug it into the SKPT/DSM port of the Pixhawk.
  • Mount the satellite rx as far as possible from other electrical/electronic components.In my case, I used a 3ft extension and mounted it on the vertical fin.
  • Connect the Pixhawk to QGC and calibrate
  • Depending on the airframe you chose during your initial setup, you can assign up to two RC channels to AUX1 and AUX2 ports of the Pixhawk. For example, you can use these channels control a camera gimbal.

If you have just the receiver only (bottom)

  • You’ll need a PPM encoder.
  • Bind the receiver to your Tx.
  • Plug the PPM encoder to the PWM ports of the receiver.
  • The other end plugs into the RCIN of the Pixhawk.
  • You’ll need to supply a separate 5v power to your receiver.
  • Connect it to QGC calibrate

Good luck.
LemonRX1