Cant arm with rc

new to px4 and pixracer. new build of 130mm quad. pixracer running standard px4 firmware. all the checks disabled - like a racer. arms fine in qgc. will not arm via rc. I feel sure i am missing something dumb - but after hours of looking I have no idea what.

All thoughts appreciated,


I guessing that you calibrated the RC? Also there is a RC parameter which selects what kind of input you have (joystick, RC and one more thing, that I do not remember right now)

Yes, and COM_RC__IN_MODE is set to RC Transmitter. I’m using DX8i and Spektrum FPV Racing rx. Seems to bind fine with 11ms framing. I wonder if there is some problem between pixracer and this rx though. RC calibration is slow, and a little finicky. Not sure if its really picking up the whole range of stick movement, and seems a little deaf to the switch channels. I’ll search for more - perhaps there is some tx/rx setup that is wrong.

When you say RC Cal is slow are you connected over radio? If so, this can be the case. But over USB it should be fast and rock solid. If it isn’t then something is out of whack with hardware setup.

This was USB, and since i began the rx has failed. Im guessing this is at least part of the problem. Waiting on stuff now :wink:

fixed. bad rx. replaced spektrum fpv racing rx and dx8i with frksy x4r and taranis 9plus. worked first time. guessing bad rx - now i gotta decide if im gonna replace it or figure out how to sqz x4r on this 130!

Its probably the new telemetry protocol on the DX8i. It will work with a DXe. We’re talking to Spektrum and a fix is on the way.

would make sense for the beginning problems - it was configuring but oddly. but these later issues were due more to a failing rx - it would no longer rebind, for example.

Hello, I met the same problem. I also cannt arm with the User’s Guide said “To arm the drone, put the throttle stick in the bottom right corner”. And now I have to arm by QGC but this is very trouble. Have you found the solution?

Thank you ! My drone is VTOL TBS.

I solved my problem when i changed to new rx and tx. uisng taranis 9d plus and frsky x4r. There also may be safety parameters that you have to change depending on how aircraft is configured. my 130mm quad does not have gps, for example, so i had to disable that in the the pixracer parameters using qgc. the various parameters are discussed elsewhere in this forum. hope this helps.