PX4FMU Driver Not Installing in Mission Planner, etc (one solution)

#1

I am not alone in seeing an install problem for PX4FMU driver. The “solution” below worked for me.

I have had a long time problem of installing PX4FMU driver for use with my Pixhawk Racers (2 off + bigger brother Pixhawk). Worked at one time!
Re-installing Mission Planner, or other, failed to install the driver PX4FMU.
The Pixhawk site does not seem to provide a driver as a separate item, not that I could find.
My latest idea was that something in my OS (WIN 7) was stopping this driver installing. I configured the OS to accept unsigned drivers, but this was not successful.
Then I thought I would try SafeMode, but this will not install anything normally. This page


allowed me to overcome that limitation. I then used px4driver.msi found in QGroundControl drivers directory, and ran this in safe mode.
On restarting in normal mode I immediately ran up Device Manager - no sign of px4fmu, BUT on plugging in a Pixhawk up came “legacy FMU (Com3)”.
I immediately did a System Backup! Trying for an Update Driver in Device Manager did not find anything better on-line. Searching the Windows directory did not uncover a newer driver.

Previously, when it did work, the driver did not say “Legacy”, but I have to assume it is fine as MP and QGroundControl now connect to the Pixracer. It is the QGroundConrtol driver so it should be fine.

Mission Planner now also connects!

It seems to me, bearing in mind that MP and QGroundControl did work when originally installed that there is something in my OS (currently) that stops a proper installation !?
Note however that I have the same problem on my laptop (Also Win7)! It seems to be a Win7 problem (but not necessarily limted to this)

I hope that this may provide a solution for others having the same big headache.