PX4 Pro Autotune in QGC Problem


I use QGC v. 4.2, hexarotor frame, firmware PX4 pro v. 1.12.3.

I have a problem with autotune. Multicopter pre-flight test is ok, then I flight in altitute mode on 10 meters height, but when I click to autotune button, I see “Ack error 3”.

Also sometimes there is an error:
“Vehicle did not respond to command: mav_cmd_set_message_interval”

How this problem solve? Thanks

Maybe you just know, what it mean “ack error 3” in pid tuning tab?

Hello, I have exactly the same issue. After pressing an auto tune button appears msg “Ack error 3”.

Unfortunately, the problem is not solved. I used also pixhawk 5x, pixhawk 4, different firmware, but appears msg “Ack error 3”.
I didn’t find anything on the internet about this.

I’m facing the same issue, any luck @butcherius , @kornat ?

px4 pro v 1.12.x,
tried different QGC verisons
pixhawk 4 FC

ACK error 3: is enum from MAV_RESULT (Result from a MAVLink command)

enum 3 is [MAV_RESULT_UNSUPPORTED], Command is not supported (unknown).



  1. Not sure, if MC_Autotune functionality is enabled in firmware build for my FC model and airframe. I couldn’t find any of MC_AT_* parameters in my parameter list.
    MC_AT_EN (INT32) or any of MC_AT_*

note: I’m using airframe quad X → DJI_M100 with pixhawk 4(FMU V5X)

Check if your px4 build has MC_AT* params enabled and MC_AT_EN set to 0

For mc with pixhawk 4, FMUV5X the mc_autotune is enabled. (If I’m reading it correctly)

Ref/ discussions:

I’m little tied up this week, would test more next week.

some more info on my build,
really appreciate, if someone with experience with autotune could comment, thanks

nsh> ver all
HW arch: PX4_FMU_V5
HW type: V500
HW version: 0x00000000
HW revision: 0x00000000
FW git-hash: 2e8918da66af37922ededee1cc2d2efffec4cfb2
FW version: Release 1.12.3 (17564671)
OS: NuttX
OS version: Release 8.2.0 (134349055)
OS git-hash: bf660cba2af81f055002b3817c87b1f63a78fd09
Build datetime: Sep 6 2021 16:39:19
Build uri: localhost
Toolchain: GNU GCC, 9.3.1 20200408 (release)
PX4GUID: 0002000000003236343532375118002a0035
MCU: STM32F76xxx, rev. Z

Builtin Apps:
tone_alarm mappydot
ekf2 bl_update
rgbled batt_smbus
gpio landing_target_estimator
px4io lps22hb
lis2mdl icm20948_i2c_passthrough
bmp280 pwm_input
adis16448 lps33hw
ak09916 nsh
flight_mode_manager ver
tune_control battery_status
reflect i2cdetect
camera_feedback serdis
commander camera_trigger
temperature_compensation roboclaw
system_time dps310
bst mc_hover_thrust_estimator
rc_update mc_rate_control
cm8jl65 irlock
icm20602 work_queue
batmon pga460
lis3mdl sih
ak8963 ms4525_airspeed
rm3100 uavcan
ina226 safety_button
param motor_ramp
mft led_control
motor_test hott_sensors
mixer uuv_att_control
pwm_out logger
camera_capture pwm
hmc5883 top
local_position_estimator gps
vl53l0x uorb
ll40ls_pwm rc_input
bmm150 sensors
gyro_fft ms5611
sh attitude_estimator_q
lightware_laser_i2c ulanding_radar
hardfault_log fake_gps
sd_bench mtd
land_detector qmc5883l
frsky_telemetry gyro_calibration
ets_airspeed airspeed_selector
pca9685 uuv_pos_control
vl53l1x mb12xx
dataman fw_pos_control_l1
hott_telemetry pmw3901
pwm_out_sim icm20689
serial_test sercon
bmi055 mc_att_control
vmount vtol_att_control
fw_att_control rover_pos_control
vcm1193l gy_us42
paw3902 lightware_laser_serial
ist8308 nshterm
srf02 dshot
bmp388 lsm303agr
sdp3x_airspeed rgbled_ncp5623c
pcf8583 send_event
dumpfile tfmini
px4flow heater
ll40ls board_adc
ads1115 mc_pos_control
listener ms5525_airspeed
rgbled_pwm ist8310
thoneflow atxxxx
esc_battery mavlink
reboot pca9685_pwm_out
load_mon teraranger
leddar_one icm20948
dmesg esc_calib
navigator perf

1.12.3 From GitHub tags for release 1.12.3. doesn’t seem to have mc_autotune_attitude_control module, all the links I posted above are from master branch. (https://github.com/PX4/PX4-Autopilot/tree/master/src/modules/mc_autotune_attitude_control), not sure if autotune was under a different module name in older builds.

Hey everyone multicopter autotune is available on master (aka v1.13-alpha), and only available on flight controllers that have the resources available to support it (IMX, F7 & H7 based)


@rroche, thank you!!! Good news, pixhawk 4 and 5x based on F7 boards. I will try to install v.1.13-alpha and then write back. @rp_frl, you can also try

@rroche, it works! Thank you


Thanks for your answear, and can you tell me how to download (aka v1.13-alpha)? My device is cuav V5+. I’m a greenhand :slight_smile:

Thanks for your answear, and can you tell me how to download (aka v1.13-alpha)? My device is cuav V5+. I’m a greenhand :slight_smile:
Looking forward to your rely.

You can use qgroundcontrol to update firmware. But you choose develover daily build (master), not stable version.

here’s the guide on how to install PX4 firmware Loading Firmware | PX4 User Guide

1 Like