Getting old Motor tab instead of the new Actuator tab

Hi I’m trying to set up a custom airframe as described in the Actuator Configutatioing and testing instructions located below, The issue is I can’t get the actuators tab, I only get the old motors tab.

In terms of debugging the issue, I have tried running a stable version and today’s daily build (2022-10-16) of QGCS.
For hardware, I freshly flashed 1.13.1 on a cube orange and an omnibus F4 with the same results.
I feel I am missing something simple but I’m really not sure how to proceed from here or get around the problem another way.

Thanks for your assistance

In version 1.13.1 the new control allocation system is not active by default. You have to manually enable it setting SYS_CTRL_ALLOC = 1 and reboot (you may have to reconfigure the airframe after that, I’m not sure.

However, in the main branch the old mixing system has been removed so you need to reed the doc for version 1.13 to find this parameter (Parameter Reference | PX4 User Guide)

That is really valuable information as I didn’t know this but unfortunately did not fix the issue even after testing on both boards.

I can enable SYS_CTRL_ALLOC but even after a full reboot and restart of QGCS I still don’t have an actuators tab. If I load an airframe (for example Generic Quadcopter or standard plane) it resets this parameter to 0 ( disabled)

Oh, I don’t know why it is not showing, sorry.

Howerver, you can flash the developer build (Loading Firmware | PX4 User Guide) which has the control allocator enabled by default

Does it have to do with the airframe you selected?

I thought so too so I’ve tried generic quad, standard Plane and the BlueROV during my testing. In all cases the SYS_CTRL_ALLOC was reset to 0 and after manually setting it to 1 there was no change in the motors tab so I don’t think it is related to the airframe selected. Now this is not an exhaustive test but if there is one that is known to work I will try that one.

I tried the Beta and that loads firmware version 1.13.0 rc1 this one had SYS_CTRL_ALLOC enabled by default and Developer and that loads 1.13.0beta but that doesn’t have a SYS_CTRL_ALLOC parameter and none of them give me the actuator tab options at least on the orange cube.

The plot thickens,
updating QGCS to the new daily version this morning (October 20th) I was able to get the actuators tab to become available when SYS_CTRL_ALLOC = 1 on the Orange Cube but not the Omnibus flight controller. The version from the 16th was not showing it for both. I did a back-to-back test where the only change was the version of QGCS.

Hi,
I had the same issue too.

I use a Pixhawk 4 (FW 1.13.1) connected to a companion computer via serial connection,
then over wifi with mavproxy to the gcs, running QGroundcontrol. And I use the generic quad airframe.

I had to update mavproxy.py to the newest version and QGCS to the new daily (Oct 20th) version.
And I had also set the parameter to SYS_CTRL_ALLOC=1. Then it works for me.

This really needs to be added to the current documentation (that you need to set SYS_CTRL_ALLOC =1). I wasted a few hours trying to manage this.